aboutsummaryrefslogtreecommitdiffstats
path: root/math/PDL
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-05-07 07:23:24 +0800
committertota <tota@FreeBSD.org>2011-05-07 07:23:24 +0800
commit5728e8743ffd0bf1c764466c689cd1db557447c1 (patch)
tree63675a1ab5b15e168e7625c5e89cf842ddb59958 /math/PDL
parent5107c07db90508a12043d35397b21855eae3f211 (diff)
downloadfreebsd-ports-gnome-5728e8743ffd0bf1c764466c689cd1db557447c1.tar.gz
freebsd-ports-gnome-5728e8743ffd0bf1c764466c689cd1db557447c1.tar.zst
freebsd-ports-gnome-5728e8743ffd0bf1c764466c689cd1db557447c1.zip
- Update to 2.4.7 [1]
- Make portlint happier PR: ports/155707 [1] Submitted by: Zhihao Yuan <lichray_AT_gmail_DOT_com> [1]
Diffstat (limited to 'math/PDL')
-rw-r--r--math/PDL/Makefile85
-rw-r--r--math/PDL/distinfo4
-rw-r--r--math/PDL/files/patch-gg12
-rw-r--r--math/PDL/files/patch-mconf.h13
-rw-r--r--math/PDL/files/patch-perldl.conf29
5 files changed, 89 insertions, 54 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index f594209871bd..92b71d917f16 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= PDL
-PORTVERSION= 2.4.4
-PORTREVISION= 8
+PORTVERSION= 2.4.7
CATEGORIES= math perl5
MASTER_SITES= CPAN/${PORTNAME}:cpan \
SF/pdl/PDL/${PORTVERSION}:sf
@@ -17,19 +16,12 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:cpan,sf
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl Data Language
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
- ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77 \
- ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
+BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
- ${SITE_PERL}/Astro/FITS/Header.pm:${PORTSDIR}/astro/p5-Astro-FITS-Header \
- ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
- ${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
-LIB_DEPENDS= plplotd.10:${PORTSDIR}/math/plplot \
- fftw.2:${PORTSDIR}/math/fftw \
- gsl.15:${PORTSDIR}/math/gsl
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ ${SITE_PERL}/Astro/FITS/Header.pm:${PORTSDIR}/astro/p5-Astro-FITS-Header
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GL= yes
PERL_CONFIGURE= yes
USE_GMAKE= yes
MAKE_ENV+= PERL5LIB=${WRKSRC}/blib/lib
@@ -39,23 +31,66 @@ PLIST_FILES= bin/pdl bin/pdldoc bin/perldl bin/pptemplate \
${SITE_PERL_REL}/${PERL_ARCH}/Inline/MakePdlppInstallable.pm
MAKE_JOBS_UNSAFE= yes
-.if defined(KITCHEN_SINK)
-RUN_DEPENDS+= ppmtogif:${PORTSDIR}/graphics/netpbm \
- mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
- saoimage:${PORTSDIR}/astro/saoimage
+OPTIONS= PGPLOT "Enable PDL::Graphics::PGPLOT" on \
+ PLPLOT "Enable PDL::Graphics::PLplot" off \
+ GL "Enable PDL::Graphics::TriD and OpenGL" on \
+ GD "Enable PDL::IO::GD" off \
+ FFTW "Enable PDL::FFTW" on \
+ GSL "Enable PDL::GSL interface" off \
+ HDF "Enable PDL::IO::HDF interface" off \
+ PROJ "Enable PDL::GIS::Proj interface" off \
+ F77 "Enable PDL::Minuit and PDL::Slatec" on \
+ READLINE "Use GNU readline" off \
+ SINK "Include PDL kitchen sink" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PGPLOT)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl
.endif
-.SILENT:
+.if defined(WITH_PLPLOT)
+LIB_DEPENDS+= plplotd.10:${PORTSDIR}/math/plplot
+.endif
+
+.if defined(WITH_GL)
+USE_GL= yes
+.endif
-.if !defined(KITCHEN_SINK)
-pre-extract:
- ${ECHO} "You can build additional functionality into PDL by defining KITCHEN_SINK"
+.if defined(WITH_GD)
+LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
.endif
-.include <bsd.port.pre.mk>
+.if defined(WITH_F77)
+BUILD_DEPENDS+= ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77
+.endif
-.if ${ARCH} == "alpha"
-BROKEN= test script t/flexraw.t fails all 26 tests
+.if defined(WITH_FFTW)
+LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
+.endif
+
+.if defined(WITH_GSL)
+LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
+.endif
+
+.if defined(WITH_HDF)
+LIB_DEPENDS+= df:${PORTSDIR}/science/hdf
+.endif
+
+.if defined(WITH_PROJ)
+LIB_DEPENDS+= proj:${PORTSDIR}/graphics/proj
+.endif
+
+.if defined(WITH_READLINE)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu
+.else
+RUN_DEPENDS+= ${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+.endif
+
+.if defined(WITH_SINK)
+RUN_DEPENDS+= ppmtogif:${PORTSDIR}/graphics/netpbm \
+ mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+ saoimage:${PORTSDIR}/astro/saoimage
.endif
post-patch:
@@ -84,4 +119,4 @@ post-install:
${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/PDL -type d | ${SORT} -r | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/PDL/distinfo b/math/PDL/distinfo
index 50d5772c919a..e1107cd8ae1c 100644
--- a/math/PDL/distinfo
+++ b/math/PDL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PDL-2.4.4.tar.gz) = e7d4dfcae14f02dac1b0b353465bb49f474304d8a6e7e139dc62fefdcb77978d
-SIZE (PDL-2.4.4.tar.gz) = 2341784
+SHA256 (PDL-2.4.7.tar.gz) = 907ecfa69fa2bdfc5d3464eab7eda9df11f647b4fb3cb87e25969bc29f710a58
+SIZE (PDL-2.4.7.tar.gz) = 2598921
diff --git a/math/PDL/files/patch-gg b/math/PDL/files/patch-gg
deleted file mode 100644
index 0177b9bd2496..000000000000
--- a/math/PDL/files/patch-gg
+++ /dev/null
@@ -1,12 +0,0 @@
---- Basic/Math/mconf.h.orig Wed Sep 25 00:57:31 2002
-+++ Basic/Math/mconf.h Wed Sep 25 00:58:06 2002
-@@ -89,7 +89,9 @@
- #endif
- #if defined __alpha && ! defined __linux
- #include <float.h>
-+#ifndef __FreeBSD__
- #include <nan.h>
-+#endif
- #endif
- #ifndef NANARG
- #define NANARG
diff --git a/math/PDL/files/patch-mconf.h b/math/PDL/files/patch-mconf.h
new file mode 100644
index 000000000000..c00a9f7b5dcb
--- /dev/null
+++ b/math/PDL/files/patch-mconf.h
@@ -0,0 +1,13 @@
+--- Basic/Math/mconf.h.orig 2010-05-08 21:43:08.000000000 -0500
++++ Basic/Math/mconf.h 2011-03-19 17:12:01.099417176 -0500
+@@ -89,8 +89,10 @@ Copyright 1984, 1987, 1989, 1995 by Step
+ #endif
+ #if defined __alpha && ! defined __linux
+ #include <float.h>
++#ifndef __FreeBSD__
+ #include <nan.h>
+ #endif
++#endif
+ #ifndef NANARG
+ #define NANARG
+ #endif
diff --git a/math/PDL/files/patch-perldl.conf b/math/PDL/files/patch-perldl.conf
index e3604acc8e0c..4da2214b2fe0 100644
--- a/math/PDL/files/patch-perldl.conf
+++ b/math/PDL/files/patch-perldl.conf
@@ -1,21 +1,20 @@
---- perldl.conf.orig Thu Aug 17 10:59:51 2006
-+++ perldl.conf Mon Oct 2 09:45:30 2006
-@@ -113,6 +113,9 @@
- # OPENGL_LIBS => undef,
- # OPENGL_INC => undef,
- # OPENGL_DEFINE => undef,
-+ OPENGL_LIBS => '-L/usr/X11R6/lib -lGL -lGLU -lXext -lX11',
-+ OPENGL_INC => '-I/usr/X11R6/include',
-+ OPENGL_DEFINE => '-DGL_GLEXT_LEGACY',
-
- # Whether or not to build the Karma interface module
-
-@@ -191,7 +194,7 @@
- # about curses to fix it
- # - 1 builds, 0 or undef does not build
+--- perldl.conf.orig 2010-08-15 12:38:21.000000000 -0500
++++ perldl.conf 2011-03-19 19:07:04.854128623 -0500
+@@ -229,7 +229,7 @@
+ # Do we build PDL::IO::Browser?
+ # default -> do not build (module needs to be updated)
#
- WITH_IO_BROWSER => 0,
+ WITH_IO_BROWSER => 1,
# Quiet Astro::FITS::Header warnings for PDL build process by default
# Eventually would be better to set undef by default, and have the
+@@ -246,7 +246,7 @@
+ # false -> don't install pdl2 support
+ # true -> force pdl2 install (default)
+
+- WITH_DEVEL_REPL => 1,
++ WITH_DEVEL_REPL => 0,
+
+ # Set this for official CPAN releases of PDL since these
+ # tests will always fail until they are fixed. It can also