aboutsummaryrefslogtreecommitdiffstats
path: root/math/R
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-03 23:15:02 +0800
committermarino <marino@FreeBSD.org>2016-08-03 23:15:02 +0800
commit4364b8401a192fc61173800459fa885a51ea2747 (patch)
tree995f39bf6ae748e3893222efa8d1b1350145f9f0 /math/R
parent8d3240d8e986c789fc9602caf9fe56e52e32b1f1 (diff)
downloadfreebsd-ports-gnome-4364b8401a192fc61173800459fa885a51ea2747.tar.gz
freebsd-ports-gnome-4364b8401a192fc61173800459fa885a51ea2747.tar.zst
freebsd-ports-gnome-4364b8401a192fc61173800459fa885a51ea2747.zip
math/R: Fix usage of ${OSVERSION} without ${OPSYS}
There are several OSVERSION checks but everything is specific to FreeBSD so the entire block is wrapped with a single OPSYS check to minimize changes to the makefile. Approved by: OSVERSION/OPSYS blanket
Diffstat (limited to 'math/R')
-rw-r--r--math/R/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index c2747f89f060..b80e30e939b7 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -163,6 +163,7 @@ PLIST_SUB= R_SOVERSION="${R_SOVERSION}" \
.include "compiler.mk"
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD
.if ${OSVERSION} > 1000052 && \
(${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == ia64 || ${ARCH} == pc98 || \
${ARCH} == sparc64)
@@ -222,6 +223,7 @@ pre-configure:
compiler and architecture: please enable the MISSING option."; \
fi
.endif
+.endif # ${OPSYS} == FreeBSD
post-install:
.for L in R Rblas Rlapack