aboutsummaryrefslogtreecommitdiffstats
path: root/math/algotutor
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2007-01-08 21:28:21 +0800
committerkevlo <kevlo@FreeBSD.org>2007-01-08 21:28:21 +0800
commit730df3e1ed8ad68a8f508b43c555d51a2550d369 (patch)
treed6dafe0b459d64132a0fda569822ff9f65eb2c64 /math/algotutor
parent77d5454080b003c17c6a2e0a5fcd2531bd8fbf5b (diff)
downloadfreebsd-ports-gnome-730df3e1ed8ad68a8f508b43c555d51a2550d369.tar.gz
freebsd-ports-gnome-730df3e1ed8ad68a8f508b43c555d51a2550d369.tar.zst
freebsd-ports-gnome-730df3e1ed8ad68a8f508b43c555d51a2550d369.zip
- Remove build-time Perl dependency
- Update MASTER_SITES - Bump PORTREVISION
Diffstat (limited to 'math/algotutor')
-rw-r--r--math/algotutor/Makefile4
-rw-r--r--math/algotutor/files/patch-algotutor2
2 files changed, 4 insertions, 2 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index cca52a113996..3d0898bdd9ea 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -7,8 +7,9 @@
PORTNAME= algotutor
PORTVERSION= 0.8.5
+PORTREVISION= 1
CATEGORIES= math
-MASTER_SITES= http://www.cyut.edu.tw/~ckhung/dl/
+MASTER_SITES= http://saturn.stu.edu.tw/~ckhung/dl/
EXTRACT_SUFX= .tgz
MAINTAINER= kevlo@FreeBSD.org
@@ -28,6 +29,7 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
utilalgo
post-patch:
+ ${REINPLACE_CMD} -e 's,#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/algotutor
${PERL} -pi -e "s'!!PREFIX!!'${PREFIX}'g" ${WRKSRC}/algotutor
do-install:
diff --git a/math/algotutor/files/patch-algotutor b/math/algotutor/files/patch-algotutor
index cccb33fc1bf4..dcc1ba0fe824 100644
--- a/math/algotutor/files/patch-algotutor
+++ b/math/algotutor/files/patch-algotutor
@@ -5,7 +5,7 @@
use strict;
use Getopt::Std;
-use lib '/usr/share/perl5/algotutor';
-+use lib '!!PREFIX!!/lib/perl5/site_perl/5.8.6/algotutor';
++use lib '!!PREFIX!!/lib/perl5/site_perl/5.8.8/algotutor';
BEGIN {
my ($path) = $0 =~ m#(.*/)#;