aboutsummaryrefslogtreecommitdiffstats
path: root/math/asir2000/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-07 21:16:35 +0800
committeredwin <edwin@FreeBSD.org>2002-11-07 21:16:35 +0800
commitcb2d80b891a1b5a458100d15ab3c499092bf8d5f (patch)
tree27087410d7c4715ce2d481b403c64b531891b062 /math/asir2000/Makefile
parentf03465fdb98a1bd5f68cd83202cab333722fbef3 (diff)
downloadfreebsd-ports-gnome-cb2d80b891a1b5a458100d15ab3c499092bf8d5f.tar.gz
freebsd-ports-gnome-cb2d80b891a1b5a458100d15ab3c499092bf8d5f.tar.zst
freebsd-ports-gnome-cb2d80b891a1b5a458100d15ab3c499092bf8d5f.zip
ports/math/asir2000 do not build. This probrem has two reasons.
1) ports/matn/pari-devel update. 2) 5-current do not build. This reasion is thread problem. This send-pr solved that problems. PR: ports/44308 Submitted by: Saito Tomokatsu <saito@asir.org>
Diffstat (limited to 'math/asir2000/Makefile')
-rw-r--r--math/asir2000/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index 991fc576149e..60a75fa5e408 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= asir
-PORTVERSION= 20020910
+PORTVERSION= 20021020
CATEGORIES= math
-MASTER_SITES= ftp://ftp.asir.org/pub/asir/src/
+MASTER_SITES= ftp://ftp.jssac.org/pub/distfiles/asir/ \
+ ftp://ftp.asir.org/pub/asir/src/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ASIR_DOC}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -24,7 +25,7 @@ CONFIGURE_ENV= OLD_PARI_VERSION=${OLD_PARI_VERSION} \
PARI_VERSION=${PARI_VERSION} \
LAPACK_VERSION=${LAPACK_VERSION}
CONFIGURE_ARGS= -oxhome ${PREFIX} -plot ${PARI} -fep -interval ${LAPACK}
-ASIR_DOC_VERSION= 20020910
+ASIR_DOC_VERSION= 20021020
ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}.tar.gz
MAN1= asir.1
@@ -36,7 +37,7 @@ LIB_DEPENDS= # dummy
OLD_PARI_DIR= ${PORTSDIR}/math/pari
OLD_PARI_VERSION= `${GREP} PORTVERSION ${OLD_PARI_DIR}/Makefile | cut -f 2`
PARI_DIR= ${PORTSDIR}/math/pari-devel
-PARI_VERSION= `${GREP} PORTVERSION ${PARI_DIR}/Makefile | cut -f 2`
+PARI_VERSION= `${GREP} MAJOR_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.`${GREP} MINOR_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.`${GREP} REV_VERSION ${PARI_DIR}/Makefile | ${GREP} -v { | cut -f 2`.alpha
.if defined(USE_OLDPARI)
LIB_DEPENDS+= pari.1:${OLD_PARI_DIR}