aboutsummaryrefslogtreecommitdiffstats
path: root/math/atlas
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-15 13:45:25 +0800
committermaho <maho@FreeBSD.org>2007-01-15 13:45:25 +0800
commit4b39d027c66f5b3749863fa6bf38eb29995b58a5 (patch)
treee0e4a2568bcc637652e6c56faa090d7126768393 /math/atlas
parent5d4ba4e4ed52d03769ec0a4f5eb60e1cb1585aa2 (diff)
downloadfreebsd-ports-gnome-4b39d027c66f5b3749863fa6bf38eb29995b58a5.tar.gz
freebsd-ports-gnome-4b39d027c66f5b3749863fa6bf38eb29995b58a5.tar.zst
freebsd-ports-gnome-4b39d027c66f5b3749863fa6bf38eb29995b58a5.zip
Atlas should not depend on GNU F77. Now
it doesn't expect existence of /usr/include/g2c.h
Diffstat (limited to 'math/atlas')
-rw-r--r--math/atlas/Makefile1
-rw-r--r--math/atlas/files/blas.h4
-rw-r--r--math/atlas/files/lapack.h4
3 files changed, 5 insertions, 4 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index eb95c77c7742..60be7015ca7b 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -44,6 +44,7 @@ CCOMPILER= ${CC}
.endif
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
diff --git a/math/atlas/files/blas.h b/math/atlas/files/blas.h
index 91a230963aab..774fbaefd0d1 100644
--- a/math/atlas/files/blas.h
+++ b/math/atlas/files/blas.h
@@ -2,12 +2,12 @@
// based on BLAS/WRAP/fblaswr.h
// in clapack.tgz, version 3.0(September 20, 2000)
// available at http://www.netlib.org/clapack/
-// and modified by Nakata Maho <chat95@mbox.kyoto-inet.or.jp>
+// and modified by Nakata Maho <maho@FreeBSD.org>
// for C++, which requires proper prototype definitions.
extern "C"
{
-#include <g2c.h>
+#include <f2c.h>
real
sdot_(integer* N,
diff --git a/math/atlas/files/lapack.h b/math/atlas/files/lapack.h
index 0e677a94bd84..fd77ee5d746f 100644
--- a/math/atlas/files/lapack.h
+++ b/math/atlas/files/lapack.h
@@ -1,12 +1,12 @@
// lapack prototypes for C++
// based on clapack.h in clapack.tgz, version 3.0(September 20, 2000)
// available at http://www.netlib.org/clapack/
-// and modified by Nakata Maho <chat95@mbox.kyoto-inet.or.jp>
+// and modified by Nakata Maho <maho@FreeBSD.org>
// for C++, which requires proper prototype definitions.
extern "C"
{
-#include <g2c.h>
+#include <f2c.h>
/* Subroutine */ int cbdsqr_(char *uplo, integer *n, integer *ncvt, integer *
nru, integer *ncc, real *d__, real *e, complex *vt, integer *ldvt,