aboutsummaryrefslogtreecommitdiffstats
path: root/math/atlas
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-10-15 02:04:51 +0800
committerbf <bf@FreeBSD.org>2012-10-15 02:04:51 +0800
commitb6be8b6a205bd6a887d180a57ce6f1a90c2383c4 (patch)
treed4037a351b0c0d11698ed0172460690c1f7e39e6 /math/atlas
parentf17aac22e7be2146c72251129146d73e0faa6d07 (diff)
downloadfreebsd-ports-gnome-b6be8b6a205bd6a887d180a57ce6f1a90c2383c4.tar.gz
freebsd-ports-gnome-b6be8b6a205bd6a887d180a57ce6f1a90c2383c4.tar.zst
freebsd-ports-gnome-b6be8b6a205bd6a887d180a57ce6f1a90c2383c4.zip
fix compiler runtime library path after recent changes to bsd.gcc.mk
Prodded by: gerald Feature safe: yes
Diffstat (limited to 'math/atlas')
-rw-r--r--math/atlas/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index ec5e8eb0703e..0312b0b212bb 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -7,7 +7,7 @@
PORTNAME= atlas
PORTVERSION= 3.8.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= math
MASTER_SITES= SF/math-${PORTNAME}/Stable/${PORTVERSION}
@@ -54,7 +54,7 @@ POINTER?= 32
.endif
.if defined(MAINTAINER_MODE)
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
.endif
.for i in DATA DOCS
@@ -87,7 +87,7 @@ PLIST_SUB+= ${opt}="@comment "
. endif
.endfor
-EXTRA_FLAGS?= -Wl,-rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
+EXTRA_FLAGS?= -Wl,-rpath=${_GCC_RUNTIME}
SHARED_FLAGS= ${PTHREAD_CFLAGS} ${PICFLAG} -DPIC
SHARED_LAPACK_WRKSRC= WRKSRC_SHARED
STATIC_FLAGS= ${PTHREAD_CFLAGS}