aboutsummaryrefslogtreecommitdiffstats
path: root/math/blitz++/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-22 06:30:39 +0800
committerbapt <bapt@FreeBSD.org>2014-07-22 06:30:39 +0800
commitcbaa909b1b3ab2250d11a15d6cc40a7b90f67e32 (patch)
treefa7caf335cae55056f70b6624a80a24dfad6faab /math/blitz++/Makefile
parenta79b822b2685d513991e5a9ed4fa7151f139c766 (diff)
downloadfreebsd-ports-gnome-cbaa909b1b3ab2250d11a15d6cc40a7b90f67e32.tar.gz
freebsd-ports-gnome-cbaa909b1b3ab2250d11a15d6cc40a7b90f67e32.tar.zst
freebsd-ports-gnome-cbaa909b1b3ab2250d11a15d6cc40a7b90f67e32.zip
Fix build with texlive
Fix build on head without makeinfo Support stage USES=libtool Use options helpers
Diffstat (limited to 'math/blitz++/Makefile')
-rw-r--r--math/blitz++/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index 352ee8674d8c..78291b160eea 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blitz++
PORTVERSION= 0.9
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math
MASTER_SITES= SF/blitz/blitz/Blitz%2B%2B%20${PORTVERSION}
DISTNAME= blitz-${PORTVERSION}
@@ -11,26 +11,27 @@ DISTNAME= blitz-${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT= C++ class library for scientific computing
-.ifndef NOPORTDOCS
-BUILD_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
- texi2dvi:${PORTSDIR}/print/texinfo
-INFO= blitz
-.else
-MAKE_ARGS= NOPORTDOCS=yes
-.endif
-
-USE_AUTOTOOLS= libtool
-USES= pathfix gmake
-CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen
+OPTIONS_DEFINE= DOCS
+
+DOCS_USE= TEX=dvipsk,formats
+DOCS_USES= makeinfo
+DOCS_INFO= blitz
+DOCS_BUILD_DEPENDS= texi2dvi:${PORTSDIR}/print/texinfo \
+ texi2html:${PORTSDIR}/textproc/texi2html
+DOCS_MAKE_ARGS_OFF= NOPORTDOCS=yes
+
+GNU_CONFIGURE= yes
+USES= libtool pathfix gmake
+CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --enable-shared
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAKE_JOBS_UNSAFE= yes
+INSTALL_TARGET= install-strip
DOCSDIR= ${PREFIX}/share/doc/blitz
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|g++|\$${CXX}|g ; \
s|"-ftemplate-depth-30|"\$${CXXFLAGS} -ftemplate-depth-30|g ; \