aboutsummaryrefslogtreecommitdiffstats
path: root/math/ceres-solver
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-13 20:44:25 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-13 20:44:25 +0800
commite3146a770fc973d0daf3403ac11ecd733285ed90 (patch)
tree8051061e978f72db55260d636b039883c2a1b3e0 /math/ceres-solver
parenta893caf1523701fd4d4432e4984222b49b6d2a0b (diff)
downloadfreebsd-ports-gnome-e3146a770fc973d0daf3403ac11ecd733285ed90.tar.gz
freebsd-ports-gnome-e3146a770fc973d0daf3403ac11ecd733285ed90.tar.zst
freebsd-ports-gnome-e3146a770fc973d0daf3403ac11ecd733285ed90.zip
math/ceres-solver: update to 1.12.0.r2.3
Changes: https://github.com/ceres-solver/ceres-solver/compare/1.12.0rc1...c5c6f55
Diffstat (limited to 'math/ceres-solver')
-rw-r--r--math/ceres-solver/Makefile6
-rw-r--r--math/ceres-solver/distinfo6
-rw-r--r--math/ceres-solver/files/patch-include_ceres_jet.h13
-rw-r--r--math/ceres-solver/pkg-plist1
4 files changed, 7 insertions, 19 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index b5a708d67efd..4eb4ee5e87ab 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= ceres-solver
-DISTVERSION= 1.12.0rc1
-PORTREVISION= 2
+DISTVERSION= 1.12.0rc2-3
+DISTVERSIONSUFFIX= -gc5c6f55
CATEGORIES= math
MAINTAINER= jbeich@FreeBSD.org
@@ -22,7 +22,7 @@ SHEBANG_FILES= examples/slam/pose_graph_*/plot_results.py \
scripts/make_docs.py
CMAKE_ARGS= -DCXX11=on -DBUILD_SHARED_LIBS=on
LDFLAGS+= -Wl,--as-needed # -lccolamd -lcholmod -lrt from suitesparse
-PLIST_SUB= VERSION=${PORTVERSION:R}
+PLIST_SUB= VERSION=${DISTVERSION:C/rc.*//}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:S/-solver//}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-solver//}
PORTDOCS= *
diff --git a/math/ceres-solver/distinfo b/math/ceres-solver/distinfo
index e5eb361d673a..ad795418aa3c 100644
--- a/math/ceres-solver/distinfo
+++ b/math/ceres-solver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474949998
-SHA256 (ceres-solver-ceres-solver-1.12.0rc1_GH0.tar.gz) = 71c4af1d9dc434327b4af509d9a5cd4f509cc60c7f349bc0fac20ca51c02569b
-SIZE (ceres-solver-ceres-solver-1.12.0rc1_GH0.tar.gz) = 3413229
+TIMESTAMP = 1478963838
+SHA256 (ceres-solver-ceres-solver-1.12.0rc2-3-gc5c6f55_GH0.tar.gz) = ab1c101dcf5a1abf6128cf3a00b9d38ad7939c07faaf89d931dc9dfb5bc4d2f9
+SIZE (ceres-solver-ceres-solver-1.12.0rc2-3-gc5c6f55_GH0.tar.gz) = 3413993
diff --git a/math/ceres-solver/files/patch-include_ceres_jet.h b/math/ceres-solver/files/patch-include_ceres_jet.h
deleted file mode 100644
index 8f3f58317dfb..000000000000
--- a/math/ceres-solver/files/patch-include_ceres_jet.h
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/ceres-solver/ceres-solver/issues/235
-
---- include/ceres/jet.h.orig 2016-10-13 16:52:02 UTC
-+++ include/ceres/jet.h
-@@ -242,7 +242,7 @@ struct Jet {
- 16 <= ::ceres::port_constants::kMaxAlignBytes;
- static constexpr int kAlignHint = kShouldAlignMatrix ?
- Eigen::AutoAlign : Eigen::DontAlign;
-- static constexpr size_t kAlignment = kShouldAlignMatrix ? 16 : 1;
-+ static constexpr size_t kAlignment = kShouldAlignMatrix ? 16 : 4;
- alignas(kAlignment) Eigen::Matrix<T, N, 1, kAlignHint> v;
- #endif
- };
diff --git a/math/ceres-solver/pkg-plist b/math/ceres-solver/pkg-plist
index 54f1bceb9cba..e0d6f563d4b9 100644
--- a/math/ceres-solver/pkg-plist
+++ b/math/ceres-solver/pkg-plist
@@ -9,6 +9,7 @@ include/ceres/covariance.h
include/ceres/crs_matrix.h
include/ceres/cubic_interpolation.h
include/ceres/dynamic_autodiff_cost_function.h
+include/ceres/dynamic_cost_function.h
include/ceres/dynamic_cost_function_to_functor.h
include/ceres/dynamic_numeric_diff_cost_function.h
include/ceres/fpclassify.h