aboutsummaryrefslogtreecommitdiffstats
path: root/math/coq/Makefile
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2010-11-09 15:09:26 +0800
committerjohans <johans@FreeBSD.org>2010-11-09 15:09:26 +0800
commitd3fc2dd1a8b1afc7523bb318d268461e84a7482f (patch)
tree530a290e87d3c84c85b4e631393ed0db2043e8db /math/coq/Makefile
parent47909c1b80b13f7a61f88d6b402a5275663e0cad (diff)
downloadfreebsd-ports-gnome-d3fc2dd1a8b1afc7523bb318d268461e84a7482f.tar.gz
freebsd-ports-gnome-d3fc2dd1a8b1afc7523bb318d268461e84a7482f.tar.zst
freebsd-ports-gnome-d3fc2dd1a8b1afc7523bb318d268461e84a7482f.zip
- Update coq to 8.3
- Add a patch to fix threading issues Submitted by: AUGER Cedric <Cedric.Auger@lri.fr>
Diffstat (limited to 'math/coq/Makefile')
-rw-r--r--math/coq/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/math/coq/Makefile b/math/coq/Makefile
index 4bfed12edba2..158899528c8c 100644
--- a/math/coq/Makefile
+++ b/math/coq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= coq
-DISTVERSION= 8.2pl1
+DISTVERSION= 8.3
PORTEPOCH= 1
CATEGORIES= math
MASTER_SITES= http://coq.inria.fr/distrib/V${DISTVERSION}/files/ \
@@ -25,25 +25,21 @@ WITH_IDE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix ${PREFIX}
CONFIGURE_ARGS+=--emacslib ${PREFIX}/share/emacs/site-lisp
-CONFIGURE_ARGS+=--reals all
CONFIGURE_ARGS+=--opt
.ifdef NOPORTDOCS
CONFIGURE_ARGS+=--with-doc none
.else
-BUILD_DEPENDS+= hevea:${PORTSDIR}/textproc/hevea
+BUILD_DEPENDS+= hevea:${PORTSDIR}/textproc/hevea \
+ latex:${PORTSDIR}/print/teTeX \
+ ${LOCALBASE}/share/texmf/tex/latex/ucs/utf8x.def:${PORTSDIR}/print/latex-ucs
PORTDOCS= *
.endif
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= OCaml bug prevents compilation
-.endif
-
-MAN1= coq-interface.1 coq-tex.1 coq_makefile.1 coqc.1 coqdep.1 coqdoc.1 \
- coqmktop.1 coqtop.1 coqtop.byte.1 coqtop.opt.1 coqwc.1 gallina.1 \
- coq-parser.1
+MAN1= coq-tex.1 coq_makefile.1 coqc.1 coqchk.1 coqdep.1 coqdoc.1 \
+ coqmktop.1 coqtop.1 coqtop.byte.1 coqtop.opt.1 coqwc.1 gallina.1
.if defined(WITH_IDE) || exists(${LOCALBASE}/bin/lablgtk2)
BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2