aboutsummaryrefslogtreecommitdiffstats
path: root/math/diehard
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-02-17 02:59:21 +0800
committerdanilo <danilo@FreeBSD.org>2014-02-17 02:59:21 +0800
commit50d3d98dd5965ad568ecb5f665125d0d4e62c309 (patch)
tree7608f811107bada15ab9c7fbe213ae721cfa9ca5 /math/diehard
parent841dcfdb5ca4519939a56c50fa82ce2fe5fbf869 (diff)
downloadfreebsd-ports-gnome-50d3d98dd5965ad568ecb5f665125d0d4e62c309.tar.gz
freebsd-ports-gnome-50d3d98dd5965ad568ecb5f665125d0d4e62c309.tar.zst
freebsd-ports-gnome-50d3d98dd5965ad568ecb5f665125d0d4e62c309.zip
- Add stage support
Diffstat (limited to 'math/diehard')
-rw-r--r--math/diehard/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/math/diehard/Makefile b/math/diehard/Makefile
index 7eb09532f1e7..fe57dded58ec 100644
--- a/math/diehard/Makefile
+++ b/math/diehard/Makefile
@@ -17,22 +17,16 @@ PLIST_SUB= DOCSDIR="share/doc/${PORTNAME}" DATADIR="share/${PORTNAME}"
DOCSLIST= NOTES readme
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|operm5\.cov|${DATADIR}/operm5.cov|g;' \
${WRKSRC}/cdoperm5.c
@${REINPLACE_CMD} -e 's|CC=gcc||g;' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/diehard ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/operm5.cov ${DATADIR}
-
-post-install:
-.ifndef(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCSLIST:S!^!${WRKSRC}/!} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/diehard ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/operm5.cov ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCSLIST:S!^!${WRKSRC}/!} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>