aboutsummaryrefslogtreecommitdiffstats
path: root/math/emc2/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-03 06:02:23 +0800
committerkrion <krion@FreeBSD.org>2004-01-03 06:02:23 +0800
commit0bfcd5fafab9fb80a3a95961b9a348d4f505c895 (patch)
tree6c3a7ee2d17e5ea3e989177265b7ac399e769d1c /math/emc2/Makefile
parentc8aed9bb4c8a612504efbb8efb61321ee59dfabe (diff)
downloadfreebsd-ports-gnome-0bfcd5fafab9fb80a3a95961b9a348d4f505c895.tar.gz
freebsd-ports-gnome-0bfcd5fafab9fb80a3a95961b9a348d4f505c895.tar.zst
freebsd-ports-gnome-0bfcd5fafab9fb80a3a95961b9a348d4f505c895.zip
Add emc2 2.15,
Emc2 is a portable, interactive and graphic software Edition of two dimensional geometry and mesh. We can create and modify the geometry (CAD), define the discretization on the lines, define the subdomains, and define some reference numbers to take into account the boundary conditions and material properties. The elements of the mesh are triangles and quadrilaterals. We have two kind of meshes: grid mesh and Delaunay Voronoo (automatic mesh). We make the edition of the mesh by moving, removing, adding vertices, by regularization, or by transformations (symmetry, rotation,..), etc. Suggested add-on: the port math/bamg. WWW: http://www-rocq1.inria.fr/gamma/cdrom/www/emc2/eng.htm PR: 60835 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'math/emc2/Makefile')
-rw-r--r--math/emc2/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/math/emc2/Makefile b/math/emc2/Makefile
new file mode 100644
index 000000000000..451b3a05a28d
--- /dev/null
+++ b/math/emc2/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: emc2
+# Date created: 16 December 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= emc2
+PORTVERSION= 2.15
+CATEGORIES= math science
+MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/emc2/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}c
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}.doc.en.ps.gz ${PORTNAME}.doc.fr.ps.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A graphic editor of two dimensional geometry and mesh
+
+RESTRICTED= No resale, contact author for commercial usage
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_XLIB= yes
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+
+.if defined(LANG) && ${LANG:Mfr*} != ""
+CFLAGS+= -DFRENCH
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/emc2
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+.for doc in ${PORTNAME}.doc.en.ps.gz ${PORTNAME}.doc.fr.ps.gz
+ @${INSTALL_DATA} ${DISTDIR}/${doc} ${DOCSDIR}
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>