aboutsummaryrefslogtreecommitdiffstats
path: root/math/fann
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2012-03-31 15:50:36 +0800
committerdhn <dhn@FreeBSD.org>2012-03-31 15:50:36 +0800
commit3e6cc3db8dc2c323c0eb6fe9134c256e161b3a63 (patch)
tree311e512a81d51386d6116c9cb5db807319f3bcb9 /math/fann
parent37778409d2fea5a4280ac9f2531d9f8381686f53 (diff)
downloadfreebsd-ports-gnome-3e6cc3db8dc2c323c0eb6fe9134c256e161b3a63.tar.gz
freebsd-ports-gnome-3e6cc3db8dc2c323c0eb6fe9134c256e161b3a63.tar.zst
freebsd-ports-gnome-3e6cc3db8dc2c323c0eb6fe9134c256e161b3a63.zip
- Update to 2.2.0
PR: ports/166533 Submitted by: Tz-Huan Huang <tzhuan@gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'math/fann')
-rw-r--r--math/fann/Makefile17
-rw-r--r--math/fann/distinfo4
-rw-r--r--math/fann/files/patch-Makefile.in11
-rw-r--r--math/fann/pkg-descr16
-rw-r--r--math/fann/pkg-plist13
5 files changed, 27 insertions, 34 deletions
diff --git a/math/fann/Makefile b/math/fann/Makefile
index cf8dda3afd24..9ea7d07a8786 100644
--- a/math/fann/Makefile
+++ b/math/fann/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= fann
-PORTVERSION= 2.1.0b
+PORTVERSION= 2.2.0
CATEGORIES= math science
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}eta
-DISTNAME= fann-2.1.0beta
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+DISTNAME= FANN-2.2.0-Source
MAINTAINER= tzhuan@csie.org
COMMENT= A free open source neural network library
-WRKSRC= ${WRKDIR}/fann-2.1.0
+WRKSRC= ${WRKDIR}/FANN-2.2.0-Source
+
+USE_CMAKE= yes
USE_ZIP= yes
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+post-patch:
+ ${REINPLACE_CMD} -e 's|/lib/pkgconfig|/libdata/pkgconfig|g' ${WRKSRC}/CMakeLists.txt
+
+post-configure:
+ ${ENV} CPP=${CPP} CC=${CC} CXX=${CXX} ${CMAKE_BIN} ${WRKSRC} -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
.include <bsd.port.mk>
diff --git a/math/fann/distinfo b/math/fann/distinfo
index 550381ba0208..ae7b67b82c0b 100644
--- a/math/fann/distinfo
+++ b/math/fann/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fann-2.1.0beta.zip) = c24171b5b9c87946bd2f50045cc8dbd0121629fe426615501db14e6043e4a141
-SIZE (fann-2.1.0beta.zip) = 4033198
+SHA256 (FANN-2.2.0-Source.zip) = 434b85fce60701c4e0066c442d60110d8e649f278e4edb814f0c0e7a1e0929fd
+SIZE (FANN-2.2.0-Source.zip) = 2285087
diff --git a/math/fann/files/patch-Makefile.in b/math/fann/files/patch-Makefile.in
deleted file mode 100644
index 7c780359e5cd..000000000000
--- a/math/fann/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Mar 4 21:27:52 2007
-+++ Makefile.in Thu Sep 14 13:40:25 2006
-@@ -179,7 +179,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- SUBDIRS = src
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = fann.pc
- EXTRA_DIST = benchmarks examples MicrosoftVisualC++6.0 MicrosoftVisualC++.Net \
- MicrosoftWindowsDll BorlandC++Builder6.0 src/include/config.h \
diff --git a/math/fann/pkg-descr b/math/fann/pkg-descr
index 29bbfa05bff5..004245531211 100644
--- a/math/fann/pkg-descr
+++ b/math/fann/pkg-descr
@@ -1,11 +1,11 @@
Fast Artificial Neural Network Library is a free open source neural network
library, which implements multilayer artificial neural networks in C with
-support for both fully connected and sparsely connected networks.
-Cross-platform execution in both fixed and floating point are supported. It
-includes a framework for easy handling of training data sets. It is easy to
-use, versatile, well documented, and fast. PHP, C++, .NET, Ada, Python, Delphi,
-Octave, Ruby, Pure Data and Mathematica bindings are available. A reference
-manual accompanies the library with examples and recommendations on how to use
-the library. A graphical user interface is also available for the library.
+support for both fully connected and sparsely connected networks. Cross-platform
+execution in both fixed and floating point are supported. It includes a
+framework for easy handling of training data sets. It is easy to use, versatile,
+well documented, and fast. Bindings to more than 15 programming languages are
+available. An easy to read introduction article and a reference manual
+accompanies the library with examples and recommendations on how to use the
+library. Several graphical user interfaces are also available for the library.
-WWW: http://leenissen.dk/fann/
+WWW: http://leenissen.dk/
diff --git a/math/fann/pkg-plist b/math/fann/pkg-plist
index 884ca8e7ffef..4127023764c3 100644
--- a/math/fann/pkg-plist
+++ b/math/fann/pkg-plist
@@ -3,6 +3,7 @@ include/doublefann.h
include/fann.h
include/fann_activation.h
include/fann_cascade.h
+include/fann_cpp.h
include/fann_data.h
include/fann_error.h
include/fann_internal.h
@@ -10,20 +11,16 @@ include/fann_io.h
include/fann_train.h
include/fixedfann.h
include/floatfann.h
-lib/libdoublefann.a
-lib/libdoublefann.la
lib/libdoublefann.so
lib/libdoublefann.so.2
-lib/libfann.a
-lib/libfann.la
+lib/libdoublefann.so.2.2.0
lib/libfann.so
lib/libfann.so.2
-lib/libfixedfann.a
-lib/libfixedfann.la
+lib/libfann.so.2.2.0
lib/libfixedfann.so
lib/libfixedfann.so.2
-lib/libfloatfann.a
-lib/libfloatfann.la
+lib/libfixedfann.so.2.2.0
lib/libfloatfann.so
lib/libfloatfann.so.2
+lib/libfloatfann.so.2.2.0
libdata/pkgconfig/fann.pc