aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnumeric/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>1999-03-09 09:13:40 +0800
committernectar <nectar@FreeBSD.org>1999-03-09 09:13:40 +0800
commit335b69e64c46a9b9a7f0d4d19ea28b244857926c (patch)
tree0df43399e68f3e4b4439fba4d1524723babff3c7 /math/gnumeric/Makefile
parentbf864b4f9741f1048d32868d9e3544a23fea1f39 (diff)
downloadfreebsd-ports-gnome-335b69e64c46a9b9a7f0d4d19ea28b244857926c.tar.gz
freebsd-ports-gnome-335b69e64c46a9b9a7f0d4d19ea28b244857926c.tar.zst
freebsd-ports-gnome-335b69e64c46a9b9a7f0d4d19ea28b244857926c.zip
Upgrade to GNOME 1.0. The following are the details:
ports/audio/esound 0.2.7 -> 0.2.8 PR ports/10422 ports/audio/gnomeaudio 0.99.8 -> 1.0.0 PR ports/10426 ports/audio/libaudiofile 0.1.5 -> 0.1.6 PR ports/10421 ports/deskutils/gnomepim 0.99.8.1 -> 1.0.1 PR ports/10435 ports/devel/ORBit 0.3.98 -> 0.4.0 PR ports/10423 ports/devel/gettext shared libs now PR ports/10293 ports/devel/glib12 1.1.16 -> 1.2.0 PR ports/10419 ports/devel/libgtop 0.99.8 -> 1.0.1 PR ports/10430 ports/games/gnomegames 0.99.8 -> 1.0.1 PR ports/10436 ports/graphics/electriceyes distfile moved PR ports/10437 ports/graphics/imlib 1.9.3 -> 1.9.4 PR ports/10424 ports/lang/gnomeobjc 0.99.3 -> 1.0.1 PR ports/10441 ports/math/gnumeric 0.6 -> 0.15 PR ports/10439 ports/misc/gnomeutils 0.99.5 -> 1.0.1 PR ports/10442 ports/sysutils/gnomeadmin 0.99.1 -> 1.0.1 PR ports/10445 ports/sysutils/gnomecontrolcenter 0.99.3.1 -> 1.0.1 PR ports/10446 ports/sysutils/gtop 0.99.2 -> 1.0.1 PR ports/10477 ports/textproc/libxml 0.99.8 -> 1.0.0 PR ports/10438 ports/www/libghttp distfile moved PR ports/10429 ports/x11/gnome 0.99.3 -> 1.0.0 PR ports/10450 ports/x11/gnomecore 0.99.8.1 -> 1.0.1 PR ports/10432 ports/x11/gnomelibs 0.99.8.1 -> 1.0.1 PR ports/10425 ports/x11-fm/gnomemc 4.5.10 -> 4.5.23 PR ports/10448 ports/x11-toolkits/gtk-engines 0.1 -> 0.5 PR ports/10427 ports/x11-toolkits/gtk12 1.1.6 -> 1.2.0 PR ports/10420 Note that repository copies were made before this commit, as follows: ports/devel/glib11-devel -> ports/devel/glib12 ports/x11-toolkits/gtk11-devel -> ports/x11-toolkits/gtk12 Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Diffstat (limited to 'math/gnumeric/Makefile')
-rw-r--r--math/gnumeric/Makefile31
1 files changed, 17 insertions, 14 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 2ae3475b4854..7a585b282742 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -1,32 +1,35 @@
# New ports collection makefile for: gnumeric
-# Version required: 0.6
+# Version required: 0.15
# Date created: 08 October 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.6 1999/01/14 20:58:40 vanilla Exp $
+# $Id: Makefile,v 1.7 1999/01/27 08:31:51 fenner Exp $
#
-DISTNAME= gnumeric-0.6
-CATEGORIES= math
+DISTNAME= gnumeric-0.15
+CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= gnumeric
+MASTER_SITE_SUBDIR= gnome-1.0/sources
MAINTAINER= nacai@iname.com
-RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml \
- gnome.1:${PORTSDIR}/x11/gnomelibs \
- guile.4:${PORTSDIR}/lang/guile
+BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
+
+# implicit dependencies:
+# gettext, xpm, gtk12, guile, gnomelibs
USE_X_PREFIX= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
- -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
+ --with-gnome=${X11BASE} --with-guile
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install: