aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnumeric/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-10-09 21:18:41 +0800
committersobomax <sobomax@FreeBSD.org>2001-10-09 21:18:41 +0800
commita3a869c67b62a47bb64a34ff323ae28b2f37d19b (patch)
tree7450583c501e8c773d51a33bd3067e2a084ea0ea /math/gnumeric/files
parentbace79c52033b5bd66bc7a60cce39035008d72d4 (diff)
downloadfreebsd-ports-gnome-a3a869c67b62a47bb64a34ff323ae28b2f37d19b.tar.gz
freebsd-ports-gnome-a3a869c67b62a47bb64a34ff323ae28b2f37d19b.tar.zst
freebsd-ports-gnome-a3a869c67b62a47bb64a34ff323ae28b2f37d19b.zip
Update to 0.71.
Diffstat (limited to 'math/gnumeric/files')
-rw-r--r--math/gnumeric/files/patch-plugins::gb::Makefile.in18
-rw-r--r--math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c50
2 files changed, 59 insertions, 9 deletions
diff --git a/math/gnumeric/files/patch-plugins::gb::Makefile.in b/math/gnumeric/files/patch-plugins::gb::Makefile.in
index 921407563055..f56b7f4e776b 100644
--- a/math/gnumeric/files/patch-plugins::gb::Makefile.in
+++ b/math/gnumeric/files/patch-plugins::gb::Makefile.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- plugins/gb/Makefile.in 2001/07/09 16:19:36 1.1
-+++ plugins/gb/Makefile.in 2001/07/09 16:19:48
-@@ -181,7 +181,7 @@
- gnum_gb_la_SOURCES = common.c common.h excel-gb-application.c excel-gb-application.h excel-gb-context.c excel-gb-context.h excel-gb-interior.c excel-gb-interior.h excel-gb-range.c excel-gb-range.h excel-gb-selection.c excel-gb-selection.h excel-gb-worksheet.c excel-gb-worksheet.h excel-gb-worksheets.c excel-gb-worksheets.h excel-gb-worksheet-function.c excel-gb-worksheet-function.h plugin.c streams.h streams.c
+--- plugins/gb/Makefile.in.orig Tue Oct 9 15:16:29 2001
++++ plugins/gb/Makefile.in Tue Oct 9 15:20:18 2001
+@@ -216,7 +216,7 @@
+ gnum_gb_la_LIBADD = \
+ $(GB_LIBS) \
+ $(GNUMERIC_LIBS) \
+- -lm @GLIB_LIBS@ -lgb -lgbrun
++ -lm @GLIB_LIBS@ -lgbrun
--gnum_gb_la_LIBADD = $(GB_LIBS) $(EXTRA_GNOME_LIBS) -lm @GLIB_LIBS@ -lgb -lgbrun
-+gnum_gb_la_LIBADD = $(GB_LIBS) $(EXTRA_GNOME_LIBS) -lm @GLIB_LIBS@ -lgbrun
-
-
- EXTRA_DIST = README main.gba gnumeric.gbp $(gnum_gb_DATA)
+ xml_in_files = plugin.xml.in
diff --git a/math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c b/math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c
new file mode 100644
index 000000000000..d6f3e2bf29df
--- /dev/null
+++ b/math/gnumeric/files/patch-plugins::psiconv::psiconv-read.c
@@ -0,0 +1,50 @@
+
+$FreeBSD$
+
+--- plugins/psiconv/psiconv-read.c 2001/10/09 12:39:33 1.1
++++ plugins/psiconv/psiconv-read.c 2001/10/09 12:51:24
+@@ -420,7 +420,7 @@
+
+ formula = psiconv_get_formula (psi_formulas, psi_cell->ref_formula);
+
+- return (formula != NULL) ? return parse_subexpr (formula) : NULL;
++ return (formula != NULL) ? parse_subexpr (formula) : NULL;
+ }
+
+ static void
+@@ -429,27 +429,27 @@
+ {
+ Cell *cell;
+ Value *val;
+- ExprTree *tree;
++ ExprTree *tree = NULL;
+ psiconv_formula psi_formula;
+
+ cell = sheet_cell_fetch (sheet, psi_cell->column, psi_cell->row);
+ if (!cell)
+ return;
+
+- val = value_new_from_psi_cell (psi_cell);
++ val = value_new_from_psi_cell (cell, psi_cell);
+
+ if (psi_cell->calculated)
+- expr = expr_new_from_formula (psi_cell, psi_formulas);
++ tree = expr_new_from_formula (psi_cell, psi_formulas);
+
+- if (expr != NULL) {
++ if (tree != NULL) {
+ /* TODO : is there a notion of parse format ?
+ * How does it store a user entered date ?
+ */
+- if (value != NULL)
+- cell_set_expr_and_value (cell, expr, val, NULL, TRUE);
++ if (val != NULL)
++ cell_set_expr_and_value (cell, tree, val, NULL, TRUE);
+ else
+- cell_set_expr (cell, expr, NULL);
+- } else if (value != NULL) {
++ cell_set_expr (cell, tree, NULL);
++ } else if (val != NULL) {
+ /* TODO : is there a notion of parse format ?
+ * How does it store a user entered date ?
+ */