aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnumeric
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-07 04:53:21 +0800
committermarcus <marcus@FreeBSD.org>2003-01-07 04:53:21 +0800
commitc126a3bc73aed754e81069b8b130e7a5aeababac (patch)
treec182d8bddead8286b1b64bfed761028395b2c929 /math/gnumeric
parent46ab9e18feed83bbd98d47ad6f2013c27769e912 (diff)
downloadfreebsd-ports-gnome-c126a3bc73aed754e81069b8b130e7a5aeababac.tar.gz
freebsd-ports-gnome-c126a3bc73aed754e81069b8b130e7a5aeababac.tar.zst
freebsd-ports-gnome-c126a3bc73aed754e81069b8b130e7a5aeababac.zip
Reduce the XML I/O buffer size from 1 MB to 768 KB. This fixes a thread[0]
overflow that caused Gnumeric to crash or hang when opening XML files. PR: 46807
Diffstat (limited to 'math/gnumeric')
-rw-r--r--math/gnumeric/Makefile1
-rw-r--r--math/gnumeric/files/patch-src_xml-io.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 3eb0bc41bec2..5d2b19810a55 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnumeric
PORTVERSION= 1.0.12
+PORTREVISION= 1
CATEGORIES?= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.0
diff --git a/math/gnumeric/files/patch-src_xml-io.c b/math/gnumeric/files/patch-src_xml-io.c
new file mode 100644
index 000000000000..8445637e409d
--- /dev/null
+++ b/math/gnumeric/files/patch-src_xml-io.c
@@ -0,0 +1,11 @@
+--- src/xml-io.c.orig Mon Jan 6 15:45:21 2003
++++ src/xml-io.c Mon Jan 6 15:44:40 2003
+@@ -67,7 +67,7 @@
+
+ /* FIXME - tune the values below */
+ /* libxml1 parser bug breaks multibyte characters on buffer margins */
+-#define XML_INPUT_BUFFER_SIZE 1024*1024
++#define XML_INPUT_BUFFER_SIZE 1024*768
+ #define N_ELEMENTS_BETWEEN_UPDATES 20
+
+ /* ------------------------------------------------------------------------- */