aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnuplot
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-06-17 04:14:35 +0800
committerGreg Lewis <glewis@FreeBSD.org>2003-06-17 04:14:35 +0800
commit761e21411cd6762773961fb222943b875d39e8d4 (patch)
treef3197ada4c5f45fd5cd3dd492027a9680016ce52 /math/gnuplot
parent8359c8a984b27f74ef8aaf5d205e6a8310b1702f (diff)
downloadfreebsd-ports-gnome-761e21411cd6762773961fb222943b875d39e8d4.tar.gz
freebsd-ports-gnome-761e21411cd6762773961fb222943b875d39e8d4.tar.zst
freebsd-ports-gnome-761e21411cd6762773961fb222943b875d39e8d4.zip
. Workaround a problem in gcc 2.95.4 when compiling with -march=pentiumpro.
Based on a patch from the submitter. PR: 46329 Submitted by: Hidenori Ishikawa <hideishi@magisystem.net>
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--math/gnuplot/files/patch-post.trm21
2 files changed, 22 insertions, 1 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 5d01deb39ada..7cb87c456e07 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnuplot
PORTVERSION= 3.7.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/math/gnuplot/files/patch-post.trm b/math/gnuplot/files/patch-post.trm
new file mode 100644
index 000000000000..3bde83a57d7a
--- /dev/null
+++ b/math/gnuplot/files/patch-post.trm
@@ -0,0 +1,21 @@
+$FreeBSD$
+
+--- term/post.trm.orig Mon Jun 16 13:57:37 2003
++++ term/post.trm Mon Jun 16 13:58:53 2003
+@@ -939,14 +939,14 @@
+ {
+ static char GPFAR psg1[] = "0 setgray\nnewpath\n";
+ struct termentry *t = term;
++float scale = (ps_common_encap ? 0.5 : 1.0)/PS_SC;
+
+ ps_page++;
+ if (!ps_common_encap)
+ fprintf(gpoutfile,"%%%%Page: %d %d\n",ps_page,ps_page);
+ fprintf(gpoutfile,"gnudict begin\ngsave\n");
+ fprintf(gpoutfile,"%d %d translate\n",ps_common_xoff, ps_common_yoff);
+- fprintf(gpoutfile,"%.3f %.3f scale\n", (ps_common_encap ? 0.5 : 1.0)/PS_SC,
+- (ps_common_encap ? 0.5 : 1.0)/PS_SC);
++ fprintf(gpoutfile,"%.3f %.3f scale\n", scale, scale);
+ if (!ps_common_portrait) {
+ fprintf(gpoutfile,"90 rotate\n0 %d translate\n", (int)(-PS_YMAX));
+ }