aboutsummaryrefslogtreecommitdiffstats
path: root/math/gringo
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2014-01-24 23:44:33 +0800
committervsevolod <vsevolod@FreeBSD.org>2014-01-24 23:44:33 +0800
commitc1e087f0c51da5c9d4c7021110c422dde5c7b7b2 (patch)
tree822590b38881578673bd2b58a743f3b22ad73068 /math/gringo
parentb69f6dc63c41b33043481f46b9e1e21ee80d571e (diff)
downloadfreebsd-ports-gnome-c1e087f0c51da5c9d4c7021110c422dde5c7b7b2.tar.gz
freebsd-ports-gnome-c1e087f0c51da5c9d4c7021110c422dde5c7b7b2.tar.zst
freebsd-ports-gnome-c1e087f0c51da5c9d4c7021110c422dde5c7b7b2.zip
- Unbreak on FreeBSD < 10
- Disable lua support as it is terribly broken - Add license - Update portrevision accordingly
Diffstat (limited to 'math/gringo')
-rw-r--r--math/gringo/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
index 674f5b93e2fe..0a16823c9f98 100644
--- a/math/gringo/Makefile
+++ b/math/gringo/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gringo
PORTVERSION= 4.2.1
DISTVERSIONSUFFIX= -source
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= potassco/${PORTNAME}/${PORTVERSION}
@@ -11,17 +12,24 @@ MASTER_SITE_SUBDIR= potassco/${PORTNAME}/${PORTVERSION}
MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Grounding algorithm based on semi-naive database evaluation
+LICENSE= GPLv3
+
BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
-USES= scons lua:51+ bison
+USES= scons bison
-MAKE_ARGS+= ${MAKE_ENV} WITH_LUA="lua-${LUA_VER}"
-CXXFLAGS+= -std=c++11 -I${LUA_INCDIR}
-LDFLAGS+= -L${LUA_LIBDIR}
+MAKE_ARGS+= ${MAKE_ENV}
+CXXFLAGS+= -std=c++11
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+USE_GCC= 4.8+
+.endif
+
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/build/release/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>