aboutsummaryrefslogtreecommitdiffstats
path: root/math/hfst
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2017-09-25 19:05:36 +0800
committerdemon <demon@FreeBSD.org>2017-09-25 19:05:36 +0800
commitfcf1fdbb93e8cfbde710e32843c4568eb79b9d7b (patch)
tree368771184377beaec5e2dc62dac181df1c76a24d /math/hfst
parent0e55af6482de30de261b466b9ef92839436ce616 (diff)
downloadfreebsd-ports-gnome-fcf1fdbb93e8cfbde710e32843c4568eb79b9d7b.tar.gz
freebsd-ports-gnome-fcf1fdbb93e8cfbde710e32843c4568eb79b9d7b.tar.zst
freebsd-ports-gnome-fcf1fdbb93e8cfbde710e32843c4568eb79b9d7b.zip
Update to version 3.13.0.
Diffstat (limited to 'math/hfst')
-rw-r--r--math/hfst/Makefile17
-rw-r--r--math/hfst/distinfo5
-rw-r--r--math/hfst/files/patch-libhfst-src-parsers-XfstCompiler.cc10
-rw-r--r--math/hfst/files/patch-tools-src-hfst-commandline.cc9
-rw-r--r--math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc10
-rw-r--r--math/hfst/pkg-plist75
6 files changed, 82 insertions, 44 deletions
diff --git a/math/hfst/Makefile b/math/hfst/Makefile
index fe2a96df3525..a19e52d96a4f 100644
--- a/math/hfst/Makefile
+++ b/math/hfst/Makefile
@@ -2,22 +2,19 @@
# $FreeBSD$
PORTNAME= hfst
-PORTVERSION= 3.8.2
-PORTREVISION= 5
+PORTVERSION= 3.13.0
CATEGORIES= math
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/source
-
-PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/
-PATCHFILES= 134d5a5aac3f.patch:-p1
MAINTAINER= demon@FreeBSD.org
-COMMENT= A toolkit for for processing natural language morphologies
+COMMENT= Toolkit for for processing natural language morphologies
+
+USE_GITHUB= yes
+GH_TAGNAME= c187d5a
-USES= libtool pathfix pkgconfig python:2 readline shebangfix
-USE_GNOME= glib20 libxml2
+USES= autoreconf libtool pathfix pkgconfig python:2 readline shebangfix
USE_GCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-readline --with-unicode-handler=glib --enable-calculate --enable-edit-metadata --enable-lexc-wrapper --enable-proc --enable-tagger --enable-xfst --enable-shuffle --enable-traverse
+CONFIGURE_ARGS= --with-readline --enable-lexc-wrapper --enable-proc --enable-tagger --enable-train-tagger --enable-xfst --enable-shuffle --enable-traverse
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
LDFLAGS+= -L${LOCALBASE}/lib
SHEBANG_FILES= tools/src/hfst-tagger/src/hfst_tagger_compute_data_statistics.py
diff --git a/math/hfst/distinfo b/math/hfst/distinfo
index fa60e0b41318..38ac1e576d52 100644
--- a/math/hfst/distinfo
+++ b/math/hfst/distinfo
@@ -1,4 +1,5 @@
-SHA256 (hfst-3.8.2.tar.gz) = bdae235271368a8d13db4a224fe8a53cf7266b8fce194cf63c96031e007e3d63
-SIZE (hfst-3.8.2.tar.gz) = 3158251
+TIMESTAMP = 1506332455
+SHA256 (hfst-hfst-3.13.0-c187d5a_GH0.tar.gz) = 5d90d1d7e6ebdf6010532a097ae1d7e170be9ab82a43d3d6018e42fb0c51cc90
+SIZE (hfst-hfst-3.13.0-c187d5a_GH0.tar.gz) = 23840495
SHA256 (134d5a5aac3f.patch) = 9f7eacf517002af2cb1eb3d48d095d0f5d2f3100adfc4edf24279245f7d7d542
SIZE (134d5a5aac3f.patch) = 1027
diff --git a/math/hfst/files/patch-libhfst-src-parsers-XfstCompiler.cc b/math/hfst/files/patch-libhfst-src-parsers-XfstCompiler.cc
new file mode 100644
index 000000000000..f19367b206df
--- /dev/null
+++ b/math/hfst/files/patch-libhfst-src-parsers-XfstCompiler.cc
@@ -0,0 +1,10 @@
+--- libhfst/src/parsers/XfstCompiler.cc.orig 2014-07-04 18:26:59.000000000 +0400
++++ libhfst/src/parsers/XfstCompiler.cc 2014-07-04 18:27:09.000000000 +0400
+@@ -18,6 +18,7 @@
+ # include <config.h>
+ #endif
+
++#define _WITH_GETLINE
+ #include <string>
+ #include <map>
+ #include <list>
diff --git a/math/hfst/files/patch-tools-src-hfst-commandline.cc b/math/hfst/files/patch-tools-src-hfst-commandline.cc
index 437fc7c464af..fd5107985afd 100644
--- a/math/hfst/files/patch-tools-src-hfst-commandline.cc
+++ b/math/hfst/files/patch-tools-src-hfst-commandline.cc
@@ -1,10 +1,11 @@
---- tools/src/hfst-commandline.cc.orig 2014-07-04 18:13:51.000000000 +0400
-+++ tools/src/hfst-commandline.cc 2014-07-04 18:14:35.000000000 +0400
-@@ -21,6 +21,7 @@
- # include <config.h>
+--- tools/src/hfst-commandline.cc.orig 2017-09-25 13:48:38.560155000 +0300
++++ tools/src/hfst-commandline.cc 2017-09-25 13:48:46.814581000 +0300
+@@ -24,6 +24,8 @@
+ # define PACKAGE_BUGREPORT ""
#endif
+#define _WITH_GETLINE
++
#include <cassert>
#include <climits>
#include <cmath>
diff --git a/math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc b/math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc
deleted file mode 100644
index 860d7f73e813..000000000000
--- a/math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/src/parsers/XfstCompiler.cc.orig 2014-07-04 18:26:59.000000000 +0400
-+++ tools/src/parsers/XfstCompiler.cc 2014-07-04 18:27:09.000000000 +0400
-@@ -18,6 +18,7 @@
- # include <config.h>
- #endif
-
-+#define _WITH_GETLINE
- #include <string>
- #include <map>
- #include <list>
diff --git a/math/hfst/pkg-plist b/math/hfst/pkg-plist
index 4f405a58f075..7d2ff0a67c94 100644
--- a/math/hfst/pkg-plist
+++ b/math/hfst/pkg-plist
@@ -12,6 +12,7 @@ bin/hfst-determinize
bin/hfst-disjunct
bin/hfst-edit-metadata
bin/hfst-expand
+bin/hfst-flookup
bin/hfst-format
bin/hfst-fst2fst
bin/hfst-fst2strings
@@ -58,20 +59,17 @@ bin/hfst-summarise
bin/hfst-summarize
bin/hfst-tag
bin/hfst-tail
+bin/hfst-tokenise
+bin/hfst-tokenize
bin/hfst-train-tagger
bin/hfst-train-tagger-loc
bin/hfst-train-tagger-system
bin/hfst-traverse
bin/hfst-twolc
-bin/hfst-twolc-loc
-bin/hfst-twolc-system
bin/hfst-txt2fst
bin/hfst-union
bin/hfst-xfst
bin/hfst_tagger_compute_data_statistics.py
-bin/htwolcpre1
-bin/htwolcpre2
-bin/htwolcpre3
include/hfst/ComposeIntersectFst.h
include/hfst/ComposeIntersectLexicon.h
include/hfst/ComposeIntersectRule.h
@@ -80,16 +78,20 @@ include/hfst/ConvertTransducerFormat.h
include/hfst/FomaTransducer.h
include/hfst/FormatSpecifiers.h
include/hfst/HarmonizeUnknownAndIdentitySymbols.h
+include/hfst/HfstBasicTransducer.h
+include/hfst/HfstBasicTransition.h
include/hfst/HfstDataTypes.h
include/hfst/HfstEpsilonHandler.h
include/hfst/HfstExceptionDefs.h
include/hfst/HfstExtractStrings.h
-include/hfst/HfstFastTransitionData.h
include/hfst/HfstFlagDiacritics.h
include/hfst/HfstInputStream.h
include/hfst/HfstLookupFlagDiacritics.h
include/hfst/HfstOlTransducer.h
include/hfst/HfstOutputStream.h
+include/hfst/HfstPrintDot.h
+include/hfst/HfstPrintPCKimmo.h
+include/hfst/HfstStrings2FstTokenizer.h
include/hfst/HfstSymbolDefs.h
include/hfst/HfstTokenizer.h
include/hfst/HfstTransducer.h
@@ -103,8 +105,10 @@ include/hfst/PmatchCompiler.h
include/hfst/SfstTransducer.h
include/hfst/TropicalWeightTransducer.h
include/hfst/XreCompiler.h
+include/hfst/hfst-string-conversions.h
include/hfst/hfst.h
include/hfst/hfst_apply_schemas.h
+include/hfst/hfstdll.h
include/hfst/implementations/ComposeIntersectFst.h
include/hfst/implementations/ComposeIntersectLexicon.h
include/hfst/implementations/ComposeIntersectRule.h
@@ -112,7 +116,8 @@ include/hfst/implementations/ComposeIntersectRulePair.h
include/hfst/implementations/ComposeIntersectUtilities.h
include/hfst/implementations/ConvertTransducerFormat.h
include/hfst/implementations/FomaTransducer.h
-include/hfst/implementations/HfstFastTransitionData.h
+include/hfst/implementations/HfstBasicTransducer.h
+include/hfst/implementations/HfstBasicTransition.h
include/hfst/implementations/HfstOlTransducer.h
include/hfst/implementations/HfstTransition.h
include/hfst/implementations/HfstTransitionGraph.h
@@ -120,6 +125,7 @@ include/hfst/implementations/HfstTropicalTransducerTransitionData.h
include/hfst/implementations/LogWeightTransducer.h
include/hfst/implementations/SfstTransducer.h
include/hfst/implementations/TropicalWeightTransducer.h
+include/hfst/implementations/XfsmTransducer.h
include/hfst/implementations/compose_intersect/ComposeIntersectFst.h
include/hfst/implementations/compose_intersect/ComposeIntersectLexicon.h
include/hfst/implementations/compose_intersect/ComposeIntersectRule.h
@@ -127,17 +133,57 @@ include/hfst/implementations/compose_intersect/ComposeIntersectRulePair.h
include/hfst/implementations/compose_intersect/ComposeIntersectUtilities.h
include/hfst/implementations/optimized-lookup/convert.h
include/hfst/implementations/optimized-lookup/pmatch.h
+include/hfst/implementations/optimized-lookup/pmatch_tokenize.h
include/hfst/implementations/optimized-lookup/transducer.h
+include/hfst/parsers/Alphabet.h
+include/hfst/parsers/CommandLine.h
+include/hfst/parsers/ConflictResolvingLeftArrowRule.h
+include/hfst/parsers/ConflictResolvingRightArrowRule.h
+include/hfst/parsers/ConstContainerIterator.h
+include/hfst/parsers/HfstTwolcDefs.h
+include/hfst/parsers/InputReader.h
+include/hfst/parsers/LeftArrowRule.h
+include/hfst/parsers/LeftArrowRuleContainer.h
+include/hfst/parsers/LeftRestrictionArrowRule.h
include/hfst/parsers/LexcCompiler.h
+include/hfst/parsers/MatchedConstContainerIterator.h
+include/hfst/parsers/MixedConstContainerIterator.h
+include/hfst/parsers/OtherSymbolTransducer.h
include/hfst/parsers/PmatchCompiler.h
+include/hfst/parsers/RightArrowRule.h
+include/hfst/parsers/RightArrowRuleContainer.h
+include/hfst/parsers/Rule.h
+include/hfst/parsers/RuleContainer.h
+include/hfst/parsers/RuleSymbolVector.h
+include/hfst/parsers/RuleVariables.h
+include/hfst/parsers/RuleVariablesConstIterator.h
+include/hfst/parsers/SfstAlphabet.h
+include/hfst/parsers/SfstBasic.h
+include/hfst/parsers/SfstCompiler.h
+include/hfst/parsers/SfstUtf8.h
+include/hfst/parsers/TwolCGrammar.h
+include/hfst/parsers/TwolcCompiler.h
+include/hfst/parsers/VariableBlock.h
+include/hfst/parsers/VariableBlockContainer.h
+include/hfst/parsers/VariableContainer.h
+include/hfst/parsers/VariableContainerBase.h
+include/hfst/parsers/VariableDefs.h
+include/hfst/parsers/VariableValueIterator.h
+include/hfst/parsers/VariableValues.h
+include/hfst/parsers/XfstCompiler.h
include/hfst/parsers/XreCompiler.h
+include/hfst/parsers/grammar_defs.h
include/hfst/parsers/lexc-utils.h
include/hfst/parsers/pmatch_utils.h
+include/hfst/parsers/string_manipulation.h
+include/hfst/parsers/xfst-utils.h
+include/hfst/parsers/xfst_help_message.h
include/hfst/parsers/xre_utils.h
+include/hfst/string-utils.h
lib/libhfst.a
lib/libhfst.so
-lib/libhfst.so.40
-lib/libhfst.so.40.0.0
+lib/libhfst.so.50
+lib/libhfst.so.50.0.0
%%PYTHON_SITELIBDIR%%/hfst_tagger_compute_data_statistics.py
%%PYTHON_SITELIBDIR%%/hfst_tagger_compute_data_statistics.pyc
%%PYTHON_SITELIBDIR%%/hfst_tagger_compute_data_statistics.pyo
@@ -160,8 +206,6 @@ man/man1/hfst-disjunct.1.gz
man/man1/hfst-edit-metadata.1.gz
man/man1/hfst-expand-equivalences.1.gz
man/man1/hfst-expand.1.gz
-man/man1/hfst-foma-wrapper.1.gz
-man/man1/hfst-foma.1.gz
man/man1/hfst-format.1.gz
man/man1/hfst-fst2fst.1.gz
man/man1/hfst-fst2strings.1.gz
@@ -208,18 +252,13 @@ man/man1/hfst-summarise.1.gz
man/man1/hfst-summarize.1.gz
man/man1/hfst-tag.1.gz
man/man1/hfst-tail.1.gz
-man/man1/hfst-train-tagger-loc.1.gz
-man/man1/hfst-train-tagger-system.1.gz
+man/man1/hfst-tokenise.1.gz
+man/man1/hfst-tokenize.1.gz
man/man1/hfst-train-tagger.1.gz
man/man1/hfst-traverse.1.gz
-man/man1/hfst-twolc-loc.1.gz
-man/man1/hfst-twolc-system.1.gz
man/man1/hfst-twolc.1.gz
man/man1/hfst-txt2fst.1.gz
man/man1/hfst-union.1.gz
man/man1/hfst-xfst.1.gz
man/man1/hfst_tagger_compute_data_statistics.py.1.gz
-man/man1/htwolcpre1.1.gz
-man/man1/htwolcpre2.1.gz
-man/man1/htwolcpre3.1.gz
share/aclocal/hfst.m4