aboutsummaryrefslogtreecommitdiffstats
path: root/math/hs-probability
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
committerGabor Pali <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
commitec29a59ec3d0472e808e9907b2f18dce2e9fe68c (patch)
treebd2ff04188a74e09a51bfecae86236b3684491e5 /math/hs-probability
parentba00ef6b8cc071eb53bf9287bfbc328da82f7eb8 (diff)
downloadfreebsd-ports-gnome-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.tar.gz
freebsd-ports-gnome-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.tar.zst
freebsd-ports-gnome-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Diffstat (limited to 'math/hs-probability')
-rw-r--r--math/hs-probability/Makefile69
-rw-r--r--math/hs-probability/pkg-plist74
2 files changed, 39 insertions, 104 deletions
diff --git a/math/hs-probability/Makefile b/math/hs-probability/Makefile
index d10cc8f4fd02..a4ef5035c025 100644
--- a/math/hs-probability/Makefile
+++ b/math/hs-probability/Makefile
@@ -8,78 +8,13 @@
PORTNAME= probability
PORTVERSION= 0.2.2
CATEGORIES= math haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= Probabilistic Functional Programming in Haskell
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-transformers>=0.0.1:${PORTSDIR}/devel/hs-transformers
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
- hs-transformers>=0.0.1:${PORTSDIR}/devel/hs-transformers
+USE_HACKAGE= transformers>=0.0.1
-GHC_VERSION= 6.10.4
-PROBABILITY_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DATADIR= ${PREFIX}/share/${DISTNAME}
PORTDATA= *
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-PROBABILITY_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- PROBABILITY_VERSION=${PROBABILITY_VERSION} \
- PROBABILITY_LIBDIR_REL=${PROBABILITY_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal
-.if !defined(NOPORTDATA)
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-.else
- cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
- --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
-.endif
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${PROBABILITY_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/math/hs-probability/pkg-plist b/math/hs-probability/pkg-plist
index 2939a0e0ecac..5d2ccf03d968 100644
--- a/math/hs-probability/pkg-plist
+++ b/math/hs-probability/pkg-plist
@@ -1,42 +1,42 @@
@comment $FreeBSD$
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSprobability-%%PROBABILITY_VERSION%%.o
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Distribution.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Alarm.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Barber.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Bayesian.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Boys.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Collection.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Diagnosis.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Dice.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/DiceAccum.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/MontyHall.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/NBoys.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Predator.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Profession.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Queuing.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/TreeGrowth.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Expectation.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Monad.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Object.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Percentage.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/PrintList.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Random.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Shape.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Show.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Simulation.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Trace.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Transition.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Visualize.hi
-%%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSprobability-%%PROBABILITY_VERSION%%.a
-%%PROBABILITY_LIBDIR_REL%%/register.sh
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Distribution.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Alarm.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Barber.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Bayesian.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Boys.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Collection.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Diagnosis.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Dice.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/DiceAccum.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/MontyHall.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/NBoys.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Predator.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Profession.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/Queuing.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example/TreeGrowth.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Expectation.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Monad.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Object.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Percentage.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/PrintList.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Random.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Shape.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Show.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Simulation.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Trace.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Transition.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Visualize.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
%%NOPORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example
-@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability
-@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric
-@dirrm %%PROBABILITY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%PROBABILITY_LIBDIR_REL%%
-@exec /bin/sh %D/%%PROBABILITY_LIBDIR_REL%%/register.sh
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability/Example
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric/Probability
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Numeric
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister probability
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old