aboutsummaryrefslogtreecommitdiffstats
path: root/math/jags/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-18 22:56:30 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-18 22:56:30 +0800
commit273d73564f089fac021d312296352ee2295f0616 (patch)
tree2eddf6976d429a8a98d85fe235e6f553c612858f /math/jags/Makefile
parent28cf12a68e072ff19c92506dfdd779a8c477bef4 (diff)
downloadfreebsd-ports-gnome-273d73564f089fac021d312296352ee2295f0616.tar.gz
freebsd-ports-gnome-273d73564f089fac021d312296352ee2295f0616.tar.zst
freebsd-ports-gnome-273d73564f089fac021d312296352ee2295f0616.zip
1: Stagify.
2: USES=libtool, bump version. Approved by: portmgr@
Diffstat (limited to 'math/jags/Makefile')
-rw-r--r--math/jags/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/math/jags/Makefile b/math/jags/Makefile
index 8a150c66d9c1..9c99492639ca 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mcmc-jags
PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF:1,2,3,4
MASTER_SITE_SUBDIR= mcmc-jags/JAGS/${S}.x/Source/:1 \
@@ -19,7 +19,7 @@ COMMENT= Just Another Gibbs Sampler
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= bison fortran gmake
+USES= bison fortran gmake libtool
USE_LDCONFIG= yes
DIST_SUBDIR= ${PORTNAME}
@@ -27,12 +27,9 @@ WRKSRC= ${WRKDIR}/JAGS-${PORTVERSION}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= jags.1
PLIST_SUB= MODULEVERSION=${S}
S= ${PORTVERSION:C|\..*||}
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
@@ -81,16 +78,13 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKDIR}/classic-bugs; ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @cd ${WRKDIR}/classic-bugs; ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
.endif
- @${ECHO_MSG} ""
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG} ""
.if defined(MAINTAINER_MODE)
BUILD_DEPENDS+= ${LOCALBASE}/lib/R/library/coda/R/coda.rdb:${PORTSDIR}/math/R-cran-coda