aboutsummaryrefslogtreecommitdiffstats
path: root/math/jags/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-12 16:00:59 +0800
committermaho <maho@FreeBSD.org>2007-01-12 16:00:59 +0800
commit3604b25ed52059d65f96a84e72493c052d588f6d (patch)
tree3697102dbb3580fe22b204b0fc8e4fa810260a77 /math/jags/Makefile
parent94c94ce156476051ebb082c4541e816211b3842d (diff)
downloadfreebsd-ports-gnome-3604b25ed52059d65f96a84e72493c052d588f6d.tar.gz
freebsd-ports-gnome-3604b25ed52059d65f96a84e72493c052d588f6d.tar.zst
freebsd-ports-gnome-3604b25ed52059d65f96a84e72493c052d588f6d.zip
Migrate to gfortran42.
Bump portrevision. Approved by: portmgr(kris)
Diffstat (limited to 'math/jags/Makefile')
-rw-r--r--math/jags/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/math/jags/Makefile b/math/jags/Makefile
index cb6c1a2e19dd..cb823cc8914d 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -8,7 +8,7 @@
PORTNAME= jags
PORTVERSION= 0.90
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://www-fis.iarc.fr/~martyn/software/jags/
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
@@ -23,17 +23,22 @@ COMMENT= Just Another Gibbs Sampler
LIB_DEPENDS= Rmath.0:${PORTSDIR}/math/libRmath
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
CONFIGURE_ARGS= --with-lapack=-lalapack --with-blas=-lf77blas
.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
CONFIGURE_ARGS= --with-lapack=-llapack --with-blas=-lblas
.endif
DIST_SUBDIR= ${PORTNAME}
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib
+CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib F77="${F77}"
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+WANT_FORTRAN= yes #dummy but future use
+FC= gfortran42
+F77= gfortran42
.include <bsd.port.pre.mk>