aboutsummaryrefslogtreecommitdiffstats
path: root/math/jsmath
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-06-02 01:39:10 +0800
committersat <sat@FreeBSD.org>2006-06-02 01:39:10 +0800
commit04aaadf93aabfed197245d3f6f06741d4bc771e0 (patch)
tree3fe0fd10ad074d76aa9585923f439511f87612d2 /math/jsmath
parent7d320e21c2aecca4062656bc791f7c21ff734237 (diff)
downloadfreebsd-ports-gnome-04aaadf93aabfed197245d3f6f06741d4bc771e0.tar.gz
freebsd-ports-gnome-04aaadf93aabfed197245d3f6f06741d4bc771e0.tar.zst
freebsd-ports-gnome-04aaadf93aabfed197245d3f6f06741d4bc771e0.zip
Add ports math/jsmath and math/jsmath-fonts:
The jsMath package provides a method of including mathematics in HTML pages that works across multiple browsers under Windows, Macintosh OS X, Linux and other flavors of unix. jsMath uses native fonts, so they resize when you change the size of the text in your browser, they print at the full resolution of your printer, and you don't have to wait for dozens of images to be downloaded in order to see the mathematics in a web page. There are also advantages for web-page authors, as there is no need to preprocess your web pages to generate any images, and the mathematics is entered in TeX form, so it is easy to create and maintain your web pages. Although it works best with the TeX fonts installed, jsMath will fall back on a collection of image-based fonts (which can still be scaled or printed at high resolution) or unicode fonts when the TeX fonts are not available. Author: Davide P. Cervone <dvpc@union.edu> WWW: http://www.math.union.edu/~dpvc/jsMath/ PR: ports/93864 (based on) Submitted by: Nicola Vitale <nivit@email.it> Approved by: krion (mentor)
Diffstat (limited to 'math/jsmath')
-rw-r--r--math/jsmath/Makefile37
-rw-r--r--math/jsmath/distinfo3
-rw-r--r--math/jsmath/pkg-descr16
-rw-r--r--math/jsmath/pkg-plist51
4 files changed, 107 insertions, 0 deletions
diff --git a/math/jsmath/Makefile b/math/jsmath/Makefile
new file mode 100644
index 000000000000..edddd8a63128
--- /dev/null
+++ b/math/jsmath/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: jsMath
+# Date created: 2006-02-23
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jsMath
+PORTVERSION= 3.3a
+CATEGORIES= math www
+MASTER_SITES= http://www.math.union.edu/~dpvc/jsMath/download/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+
+MAINTAINER= nivit@email.it
+COMMENT= A Javascript tool for including mathematics in web pages
+
+USE_ZIP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
+PLIST_SUB+= WWWDIR=${WWWDIR:S,^${PREFIX}/,,}
+
+OPTIONS= IMAGE_FONTS "Enable image fonts" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IMAGE_FONTS)
+RUN_DEPENDS+= ${WWWDIR}/fonts/cm-fonts/alpha/def.js:${PORTSDIR}/math/jsmath-fonts
+.endif
+
+do-install:
+ @${INSTALL} -d ${WWWDIR}
+ @${CP} -Rp ${WRKSRC}/ ${WWWDIR}/
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WWWDIR}/
+ @${CHMOD} -R go-w ${WWWDIR}/
+
+.include <bsd.port.post.mk>
diff --git a/math/jsmath/distinfo b/math/jsmath/distinfo
new file mode 100644
index 000000000000..a5e769ea6893
--- /dev/null
+++ b/math/jsmath/distinfo
@@ -0,0 +1,3 @@
+MD5 (jsMath-3.3a.zip) = df3fef93c46059362d4c8f651479f7be
+SHA256 (jsMath-3.3a.zip) = 301f453bfeecf43581382a7566afbb03b2ac16c56e90818396b467b094c7ac6d
+SIZE (jsMath-3.3a.zip) = 258543
diff --git a/math/jsmath/pkg-descr b/math/jsmath/pkg-descr
new file mode 100644
index 000000000000..e90396318452
--- /dev/null
+++ b/math/jsmath/pkg-descr
@@ -0,0 +1,16 @@
+The jsMath package provides a method of including mathematics in HTML pages
+that works across multiple browsers under Windows, Macintosh OS X, Linux and
+other flavors of unix. jsMath uses native fonts, so they resize when you
+change the size of the text in your browser, they print at the full resolution
+of your printer, and you don't have to wait for dozens of images to be
+downloaded in order to see the mathematics in a web page. There are also
+advantages for web-page authors, as there is no need to preprocess your
+web pages to generate any images, and the mathematics is entered in TeX form,
+so it is easy to create and maintain your web pages.
+
+Although it works best with the TeX fonts installed, jsMath will fall back
+on a collection of image-based fonts (which can still be scaled or printed
+at high resolution) or unicode fonts when the TeX fonts are not available.
+
+Author: Davide P. Cervone <dvpc@union.edu>
+WWW: http://www.math.union.edu/~dpvc/jsMath/
diff --git a/math/jsmath/pkg-plist b/math/jsmath/pkg-plist
new file mode 100644
index 000000000000..fe0b3e049800
--- /dev/null
+++ b/math/jsmath/pkg-plist
@@ -0,0 +1,51 @@
+%%WWWDIR%%/COPYING.txt
+%%WWWDIR%%/blank.gif
+%%WWWDIR%%/extensions/AMSsymbols.js
+%%WWWDIR%%/extensions/HTML.js
+%%WWWDIR%%/extensions/bbox.js
+%%WWWDIR%%/extensions/boldsymbol.js
+%%WWWDIR%%/extensions/double-click.js
+%%WWWDIR%%/extensions/fbox.js
+%%WWWDIR%%/extensions/font.js
+%%WWWDIR%%/extensions/leaders.js
+%%WWWDIR%%/extensions/mathchoice.js
+%%WWWDIR%%/extensions/mimeTeX.js
+%%WWWDIR%%/extensions/moreArrows.js
+%%WWWDIR%%/extensions/newcommand.js
+%%WWWDIR%%/extensions/underset-overset.js
+%%WWWDIR%%/jsMath-BaKoMa-fonts.js
+%%WWWDIR%%/jsMath-autoload.html
+%%WWWDIR%%/jsMath-controls.html
+%%WWWDIR%%/jsMath-fallback-mac-mozilla.js
+%%WWWDIR%%/jsMath-fallback-mac-msie.js
+%%WWWDIR%%/jsMath-fallback-mac.js
+%%WWWDIR%%/jsMath-fallback-pc.js
+%%WWWDIR%%/jsMath-fallback-symbols.js
+%%WWWDIR%%/jsMath-fallback-unix.js
+%%WWWDIR%%/jsMath-global-controls.html
+%%WWWDIR%%/jsMath-global.html
+%%WWWDIR%%/jsMath-loader-omniweb4.js
+%%WWWDIR%%/jsMath-loader.html
+%%WWWDIR%%/jsMath-msie-mac.js
+%%WWWDIR%%/jsMath-old-browsers.js
+%%WWWDIR%%/jsMath.js
+%%WWWDIR%%/plugins/CHMmode.js
+%%WWWDIR%%/plugins/autoload.js
+%%WWWDIR%%/plugins/global.js
+%%WWWDIR%%/plugins/mimeTeX.js
+%%WWWDIR%%/plugins/noCache.js
+%%WWWDIR%%/plugins/noGlobal.js
+%%WWWDIR%%/plugins/noImageFonts.js
+%%WWWDIR%%/plugins/spriteImageFonts.js
+%%WWWDIR%%/plugins/tex2math.js
+%%WWWDIR%%/uncompressed/def.js
+%%WWWDIR%%/uncompressed/font.js
+%%WWWDIR%%/uncompressed/jsMath-fallback-mac.js
+%%WWWDIR%%/uncompressed/jsMath-fallback-pc.js
+%%WWWDIR%%/uncompressed/jsMath-fallback-symbols.js
+%%WWWDIR%%/uncompressed/jsMath-fallback-unix.js
+%%WWWDIR%%/uncompressed/jsMath.js
+@dirrm %%WWWDIR%%/extensions
+@dirrm %%WWWDIR%%/plugins
+@dirrm %%WWWDIR%%/uncompressed
+@dirrmtry %%WWWDIR%%