aboutsummaryrefslogtreecommitdiffstats
path: root/math/kcalc/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 02:13:24 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 02:13:24 +0800
commit2415bff2912c7ead959fe11d9b6dc97b940c820d (patch)
tree6bb660b2370ef4a28fd556e621311745129c03c4 /math/kcalc/Makefile
parentd7a8f169f07938dcb72eddf5f0718b46e8cf285f (diff)
downloadfreebsd-ports-gnome-2415bff2912c7ead959fe11d9b6dc97b940c820d.tar.gz
freebsd-ports-gnome-2415bff2912c7ead959fe11d9b6dc97b940c820d.tar.zst
freebsd-ports-gnome-2415bff2912c7ead959fe11d9b6dc97b940c820d.zip
New port: KDE Applications math/
* math/analitza * math/cantor * math/kalgebra * math/kbruch * math/kcalc * math/kig * math/kmplot * math/rocs This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Diffstat (limited to 'math/kcalc/Makefile')
-rw-r--r--math/kcalc/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
new file mode 100644
index 000000000000..3b18ad725dac
--- /dev/null
+++ b/math/kcalc/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= kcalc
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= math kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Scientific calculator for KDE
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-xsl \
+ docbook-xml>0:textproc/docbook-xml
+
+USES= cmake:outsource gettext kde:5 tar:xz
+USE_KDE= auth codecs coreaddons ecm config configwidgets doctools \
+ guiaddons i18n init notifications widgetsaddons xmlgui
+USE_QT5= core dbus gui widgets xml \
+ buildtools_build qmake_build
+
+.include <bsd.port.mk>