aboutsummaryrefslogtreecommitdiffstats
path: root/math/lapack/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /math/lapack/Makefile
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'math/lapack/Makefile')
-rw-r--r--math/lapack/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index 23755a8d4f88..3fa3e1b2c87f 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -117,9 +117,9 @@ post-patch:
do-build: ${MAN_TARGET} build-profile build-shared build-static
.for o in PROFILE SHARED STATIC
-build-${o:L}: patch
+build-${o:tl}: patch
.if ${PORT_OPTIONS:M${o}}
- ${PRINTF} "\n\nBuilding ${o:L} libraries:\n\n\n"
+ ${PRINTF} "\n\nBuilding ${o:tl} libraries:\n\n\n"
cd ${WRKSRC_${o}}; ${SETENV} ${MAKE_ENV} EXTRAFLAGS="${FFLAGS_${o}}" \
${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} ARCH="${AR}" ${ALL_TARGET}
@@ -153,9 +153,9 @@ TESTS ?= test-profile
check regression-test test: ${TESTS}
.for o in PROFILE SHARED STATIC
-test-${o:L}: build-${o:L}
+test-${o:tl}: build-${o:tl}
.if ${PORT_OPTIONS:M${o}}
- @${PRINTF} "\n\nTesting ${o:L} libraries:\n\n\n"
+ @${PRINTF} "\n\nTesting ${o:tl} libraries:\n\n\n"
@cd ${WRKSRC_${o}}; ${SETENV} ${MAKE_ENV} EXTRAFLAGS="${FFLAGS_${o}}" \
${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} ARCH="${AR}" ${TEST_TARGET}
.if defined(BLAS_SLAVEPORT)