aboutsummaryrefslogtreecommitdiffstats
path: root/math/lensnns
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-05 05:06:18 +0800
committerMartin Wilke <miwi@FreeBSD.org>2007-06-05 05:06:18 +0800
commit992ae451699e8992a31c4cb5566d35a091912b62 (patch)
tree6d947ada4ff61ac9409a5769c6cc14c332d39ca6 /math/lensnns
parent5ab7ffdeff5561202cc6d9c751af27b2903efa64 (diff)
downloadfreebsd-ports-gnome-992ae451699e8992a31c4cb5566d35a091912b62.tar.gz
freebsd-ports-gnome-992ae451699e8992a31c4cb5566d35a091912b62.tar.zst
freebsd-ports-gnome-992ae451699e8992a31c4cb5566d35a091912b62.zip
Lens is an efficient, yet flexible, neural network simulator that runs on
a variety of platforms, is able to handle large, complex simulations, but is also reasonably easy for novices to operate. PR: ports/112577 Submitted by: Jason W. Bacon <bacon at smithers.neuro.mcw.edu>
Diffstat (limited to 'math/lensnns')
-rw-r--r--math/lensnns/Makefile68
-rw-r--r--math/lensnns/distinfo3
-rw-r--r--math/lensnns/files/lensnns.1.in21
-rw-r--r--math/lensnns/files/patch-Makefile27
-rw-r--r--math/lensnns/files/patch-Src-Makefile25
-rw-r--r--math/lensnns/files/patch-Src-sysext.h16
-rw-r--r--math/lensnns/files/pkg-message.in19
-rw-r--r--math/lensnns/pkg-descr3
-rw-r--r--math/lensnns/pkg-plist234
9 files changed, 416 insertions, 0 deletions
diff --git a/math/lensnns/Makefile b/math/lensnns/Makefile
new file mode 100644
index 000000000000..f53970b3e8c8
--- /dev/null
+++ b/math/lensnns/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: lensnns
+# Date created: 9 jan 2007
+# Whom: Jason W. Bacon <bacon@smithers.neuro.mcw.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lensnns
+PORTVERSION= 2.63
+CATEGORIES= math science
+MASTER_SITES= http://tedlab.mit.edu/~dr/Lens/Dist/ \
+ http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
+DISTNAME= lens
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Light Efficient Neural Network Simulator
+
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83 \
+ tk83.1:${PORTSDIR}/x11-toolkits/tk83
+
+USE_GMAKE= yes
+
+MAKE_ENV+= HOSTTYPE="FreeBSD"
+
+MAN1= lensnns.1
+
+SUB_FILES= pkg-message lensnns.1
+PKGMESSAGE= ${WRKDIR}/pkg-message
+WEB_BROWSER?= konqueror
+
+pre-everything::
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "========================================================"
+ @${ECHO_CMD} "The default WEB browser for viewing the manual is KDE's"
+ @${ECHO_CMD} "konqueror. If you want to change this, type Ctrl+C now,"
+ @${ECHO_CMD} "and run make again with -DWEB_BROWSER, e.g."
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " make -DWEB_BROWSER=firefox"
+ @${ECHO_CMD} "========================================================"
+ @${ECHO_CMD} ""
+
+post-extract:
+ ${MKDIR} ${WRKDIR}/lens
+ ${MV} ${WRKDIR}/[A-Z]* ${WRKDIR}/lens
+ ${REINPLACE_CMD} 's|netscape|${WEB_BROWSER}|g' ${WRKSRC}/Src/lensrc.tcl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bin/FreeBSD/alens-2.63 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bin/FreeBSD/lens-2.63 ${PREFIX}/bin
+ ${LN} -s ${PREFIX}/bin/alens-2.63 ${PREFIX}/bin/alensnns
+ ${LN} -s ${PREFIX}/bin/lens-2.63 ${PREFIX}/bin/lensnns
+ ${INSTALL_MAN} ${WRKDIR}/lensnns.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}/Src/Images
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}/Examples
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}/Commands
+ ${INSTALL_DATA} ${WRKSRC}/Src/*.tcl \
+ ${PREFIX}/share/${PORTNAME}/Src
+ ${INSTALL_DATA} ${WRKSRC}/Src/Images/* \
+ ${PREFIX}/share/${PORTNAME}/Src/Images
+ ${INSTALL_DATA} ${WRKSRC}/Examples/* \
+ ${PREFIX}/share/${PORTNAME}/Examples
+ ${INSTALL_DATA} ${WRKSRC}/Commands/* \
+ ${PREFIX}/share/${PORTNAME}/Commands
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/math/lensnns/distinfo b/math/lensnns/distinfo
new file mode 100644
index 000000000000..57dfce1d3d84
--- /dev/null
+++ b/math/lensnns/distinfo
@@ -0,0 +1,3 @@
+MD5 (lens.tar.gz) = de9a61b851dbf16ea596d5adac315f86
+SHA256 (lens.tar.gz) = e884cf7e64fd1be7389b484cc899eb611d631149f68d3d185a32e855026b1933
+SIZE (lens.tar.gz) = 7678205
diff --git a/math/lensnns/files/lensnns.1.in b/math/lensnns/files/lensnns.1.in
new file mode 100644
index 000000000000..4a7f74d26508
--- /dev/null
+++ b/math/lensnns/files/lensnns.1.in
@@ -0,0 +1,21 @@
+.TH LENS 1
+.SH NAME \" Section header
+.PP
+
+LENS \- Light Efficient (Neural) Network Simulator
+
+.SH "DESCRIPTION"
+
+To use the default installation, set LENSDIR to %%DATADIR%%.
+
+If you want to customize anything in this directory, make a personal
+copy of %%DATADIR%%, and set LENSDIR to the full pathname of your
+own copy.
+
+For information on using LENS, please see the online documentation at
+http://tedlab.mit.edu/~dr/Lens/.
+
+.SH "PORT MAINTAINER"
+.nf
+.na
+Jason W. Bacon
diff --git a/math/lensnns/files/patch-Makefile b/math/lensnns/files/patch-Makefile
new file mode 100644
index 000000000000..fada5cea3cda
--- /dev/null
+++ b/math/lensnns/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig Tue Dec 9 13:13:54 2003
++++ Makefile Thu May 10 11:19:20 2007
+@@ -6,7 +6,7 @@
+ #CFLAGS = -w1 -O3 -march=pentiumiii -mcpu=pentiumpro -DAVOID_NAN_TEST
+ #MACHINE = INTEL
+ MAKE = /usr/bin/make
+-SYSLIB = -export-dynamic -ldl -L/usr/X11R6/lib
++SYSLIB = -export-dynamic -ldl -L${X11BASE}/lib
+
+ # Windows 95/98/NT using Cygwin:
+ ifeq ($(HOSTTYPE),i686)
+@@ -14,6 +14,15 @@
+ CFLAGS = -Wall -O4 -march=i486
+ MAKE = make
+ EXT = .exe
++ SYSLIB =
++endif
++# FreeBSD
++ifeq ($(HOSTTYPE),FreeBSD)
++ MACHINE = FREEBSD
++ MAKE = gmake
++ CC = cc
++ CFLAGS = -pipe -O -DAVOID_NAN_TEST -DHAVE_LIMITS_H -DHAVE_UNISTD_H
++ EXT =
+ SYSLIB =
+ endif
+ # Macintosh X:
diff --git a/math/lensnns/files/patch-Src-Makefile b/math/lensnns/files/patch-Src-Makefile
new file mode 100644
index 000000000000..695a2feedcb8
--- /dev/null
+++ b/math/lensnns/files/patch-Src-Makefile
@@ -0,0 +1,25 @@
+--- Src/Makefile.orig Tue Dec 9 13:13:53 2003
++++ Src/Makefile Thu May 10 11:20:40 2007
+@@ -11,6 +11,14 @@
+ INCL= -I$(TCLDIR)/include
+ LIBS= -L$(TCLDIR)/lib -ltk83 -ltcl83 -lm $(SYSLIB)
+ else
++ifeq ($(MACHINE),FREEBSD)
++ O= ../Obj/$(HOSTTYPE)
++ TCLVER= 8.3
++ TCLDIR= /usr/local/include
++ BINDIR= $(TOP)/Bin/$(HOSTTYPE)
++ INCL= -I$(TCLDIR)/tcl$(TCLVER)/generic -I$(TCLDIR)/tk$(TCLVER)/generic -I${X11BASE}/include
++ LIBS= -L$(BINDIR) -L/usr/local/lib -L${X11BASE}/lib -ltk83 -ltcl83 -lm -lX11 $(SYSLIB)
++else
+ O= ../Obj/$(HOSTTYPE)
+ TCLVER= 8.3.4
+ TCLDIR= ../TclTk
+@@ -24,6 +32,7 @@
+ INCL= -I$(TCLDIR)/tcl$(TCLVER)/generic -I$(TCLDIR)/tk$(TCLVER)/generic
+ LIBS= -L$(BINDIR) -ltk8.3 -ltcl8.3 -lm -lX11 $(SYSLIB)
+ endif
++endif
+ endif
+ EXEC_OBJS= $(O)/main.o $(patsubst %,$(O)/%.o,$(SRCS))
+ LIB_OBJS= $(O)/library.o $(patsubst %,$(O)/%.o,$(SRCS))
diff --git a/math/lensnns/files/patch-Src-sysext.h b/math/lensnns/files/patch-Src-sysext.h
new file mode 100644
index 000000000000..d1097ee3bf15
--- /dev/null
+++ b/math/lensnns/files/patch-Src-sysext.h
@@ -0,0 +1,16 @@
+--- Src/sysext.h.orig Tue Dec 9 13:13:53 2003
++++ Src/sysext.h Thu May 10 10:59:36 2007
+@@ -3,10 +3,8 @@
+ #ifndef SYSEXT_H
+ #define SYSEXT_H
+
+-/*
+-#ifdef MACHINE_YOURMACHINE
+- include headers or define macros as necessary
+-#endif
+-*/
++#if BYTE_ORDER == LITTLE_ENDIAN
++# define LITTLE_END
++#endif /* LITTLE_END */
+
+ #endif /* SYSEXT_H */
diff --git a/math/lensnns/files/pkg-message.in b/math/lensnns/files/pkg-message.in
new file mode 100644
index 000000000000..00853dcbec09
--- /dev/null
+++ b/math/lensnns/files/pkg-message.in
@@ -0,0 +1,19 @@
+===========================================================================
+
+For quick instructions, type
+
+ man lensnns
+
+To use the default configuration, set the environment variable LENSDIR to
+
+ %%DATADIR%%
+
+If you want to customize your environment, make a complete copy of
+
+ %%DATADIR%%
+
+and set LENSDIR to the full pathname of your copy.
+
+Firefox is required to view the manual from the Help menu.
+
+===========================================================================
diff --git a/math/lensnns/pkg-descr b/math/lensnns/pkg-descr
new file mode 100644
index 000000000000..3cd328003360
--- /dev/null
+++ b/math/lensnns/pkg-descr
@@ -0,0 +1,3 @@
+Lens is an efficient, yet flexible, neural network simulator that runs on
+a variety of platforms, is able to handle large, complex simulations, but
+is also reasonably easy for novices to operate.
diff --git a/math/lensnns/pkg-plist b/math/lensnns/pkg-plist
new file mode 100644
index 000000000000..3eb5b1e70668
--- /dev/null
+++ b/math/lensnns/pkg-plist
@@ -0,0 +1,234 @@
+bin/alensnns
+bin/alens-2.63
+bin/lensnns
+bin/lens-2.63
+%%DATADIR%%/Commands/addGroup.txt
+%%DATADIR%%/Commands/addLinkType.txt
+%%DATADIR%%/Commands/addNet.txt
+%%DATADIR%%/Commands/alias.txt
+%%DATADIR%%/Commands/autoPlot.txt
+%%DATADIR%%/Commands/cd.txt
+%%DATADIR%%/Commands/changeGroupType.txt
+%%DATADIR%%/Commands/clientInfo.txt
+%%DATADIR%%/Commands/close.txt
+%%DATADIR%%/Commands/closeNetOutputFile.txt
+%%DATADIR%%/Commands/connectGroupToUnits.txt
+%%DATADIR%%/Commands/connectGroups.txt
+%%DATADIR%%/Commands/connectUnits.txt
+%%DATADIR%%/Commands/copyConnect.txt
+%%DATADIR%%/Commands/copyUnitValues.txt
+%%DATADIR%%/Commands/deleteExampleSets.txt
+%%DATADIR%%/Commands/deleteGroupInputs.txt
+%%DATADIR%%/Commands/deleteGroupOutputs.txt
+%%DATADIR%%/Commands/deleteGroups.txt
+%%DATADIR%%/Commands/deleteLinkType.txt
+%%DATADIR%%/Commands/deleteLinks.txt
+%%DATADIR%%/Commands/deleteNets.txt
+%%DATADIR%%/Commands/deleteUnitInputs.txt
+%%DATADIR%%/Commands/deleteUnitOutputs.txt
+%%DATADIR%%/Commands/deltaBarDelta.txt
+%%DATADIR%%/Commands/disconnectGroupUnit.txt
+%%DATADIR%%/Commands/disconnectGroups.txt
+%%DATADIR%%/Commands/disconnectUnits.txt
+%%DATADIR%%/Commands/doExample.txt
+%%DATADIR%%/Commands/dougsMomentum.txt
+%%DATADIR%%/Commands/drawUnits.txt
+%%DATADIR%%/Commands/elmanConnect.txt
+%%DATADIR%%/Commands/eval.txt
+%%DATADIR%%/Commands/exampleSetMode.txt
+%%DATADIR%%/Commands/exec.txt
+%%DATADIR%%/Commands/exit.txt
+%%DATADIR%%/Commands/exportGraph.txt
+%%DATADIR%%/Commands/expr.txt
+%%DATADIR%%/Commands/for.txt
+%%DATADIR%%/Commands/foreach.txt
+%%DATADIR%%/Commands/freezeWeights.txt
+%%DATADIR%%/Commands/getObject.txt
+%%DATADIR%%/Commands/getSeed.txt
+%%DATADIR%%/Commands/glob.txt
+%%DATADIR%%/Commands/graph.txt
+%%DATADIR%%/Commands/graphObject.txt
+%%DATADIR%%/Commands/groupType.txt
+%%DATADIR%%/Commands/healUnits.txt
+%%DATADIR%%/Commands/help.txt
+%%DATADIR%%/Commands/history.txt
+%%DATADIR%%/Commands/if.txt
+%%DATADIR%%/Commands/index.txt
+%%DATADIR%%/Commands/lesionLinks.txt
+%%DATADIR%%/Commands/lesionUnits.txt
+%%DATADIR%%/Commands/loadExamples.txt
+%%DATADIR%%/Commands/loadWeights.txt
+%%DATADIR%%/Commands/loadXerionWeights.txt
+%%DATADIR%%/Commands/ls.txt
+%%DATADIR%%/Commands/manual.txt
+%%DATADIR%%/Commands/momentum.txt
+%%DATADIR%%/Commands/moveExamples.txt
+%%DATADIR%%/Commands/nice.txt
+%%DATADIR%%/Commands/noiseType.txt
+%%DATADIR%%/Commands/open.txt
+%%DATADIR%%/Commands/openNetOutputFile.txt
+%%DATADIR%%/Commands/orderGroups.txt
+%%DATADIR%%/Commands/path.txt
+%%DATADIR%%/Commands/pid.txt
+%%DATADIR%%/Commands/plotAll.txt
+%%DATADIR%%/Commands/plotRow.txt
+%%DATADIR%%/Commands/polarity.txt
+%%DATADIR%%/Commands/printLinkValues.txt
+%%DATADIR%%/Commands/printUnitValues.txt
+%%DATADIR%%/Commands/puts.txt
+%%DATADIR%%/Commands/pwd.txt
+%%DATADIR%%/Commands/rand.txt
+%%DATADIR%%/Commands/randInt.txt
+%%DATADIR%%/Commands/randWeights.txt
+%%DATADIR%%/Commands/repeat.txt
+%%DATADIR%%/Commands/resetDerivs.txt
+%%DATADIR%%/Commands/resetExampleSets.txt
+%%DATADIR%%/Commands/resetNet.txt
+%%DATADIR%%/Commands/resetPlot.txt
+%%DATADIR%%/Commands/resetUnitValues.txt
+%%DATADIR%%/Commands/return.txt
+%%DATADIR%%/Commands/saveExamples.txt
+%%DATADIR%%/Commands/saveParameters.txt
+%%DATADIR%%/Commands/saveWeights.txt
+%%DATADIR%%/Commands/seed.txt
+%%DATADIR%%/Commands/sendEval.txt
+%%DATADIR%%/Commands/sendObject.txt
+%%DATADIR%%/Commands/set.txt
+%%DATADIR%%/Commands/setLinkValues.txt
+%%DATADIR%%/Commands/setObject.txt
+%%DATADIR%%/Commands/setTime.txt
+%%DATADIR%%/Commands/signal.txt
+%%DATADIR%%/Commands/source.txt
+%%DATADIR%%/Commands/startClient.txt
+%%DATADIR%%/Commands/startServer.txt
+%%DATADIR%%/Commands/steepest.txt
+%%DATADIR%%/Commands/stopClient.txt
+%%DATADIR%%/Commands/stopServer.txt
+%%DATADIR%%/Commands/switch.txt
+%%DATADIR%%/Commands/test.txt
+%%DATADIR%%/Commands/thawWeights.txt
+%%DATADIR%%/Commands/time.txt
+%%DATADIR%%/Commands/trace.txt
+%%DATADIR%%/Commands/train.txt
+%%DATADIR%%/Commands/trainParallel.txt
+%%DATADIR%%/Commands/unalias.txt
+%%DATADIR%%/Commands/unset.txt
+%%DATADIR%%/Commands/updateGraphs.txt
+%%DATADIR%%/Commands/updateWeights.txt
+%%DATADIR%%/Commands/useNet.txt
+%%DATADIR%%/Commands/useTestingSet.txt
+%%DATADIR%%/Commands/useTrainingSet.txt
+%%DATADIR%%/Commands/verbosity.txt
+%%DATADIR%%/Commands/view.txt
+%%DATADIR%%/Commands/viewConsole.txt
+%%DATADIR%%/Commands/viewLinks.txt
+%%DATADIR%%/Commands/viewObject.txt
+%%DATADIR%%/Commands/viewUnits.txt
+%%DATADIR%%/Commands/wait.txt
+%%DATADIR%%/Commands/waitForClients.txt
+%%DATADIR%%/Commands/while.txt
+%%DATADIR%%/Examples/adder10.ex.gz
+%%DATADIR%%/Examples/adder10.gen
+%%DATADIR%%/Examples/adder10.in
+%%DATADIR%%/Examples/adder2.ex.gz
+%%DATADIR%%/Examples/adder2.gen
+%%DATADIR%%/Examples/adder2.in
+%%DATADIR%%/Examples/bench.ex
+%%DATADIR%%/Examples/bench.in
+%%DATADIR%%/Examples/boltz-complete.in
+%%DATADIR%%/Examples/boltz.ex
+%%DATADIR%%/Examples/boltz.in
+%%DATADIR%%/Examples/client.tcl
+%%DATADIR%%/Examples/crazyxor.ex
+%%DATADIR%%/Examples/digits.ex
+%%DATADIR%%/Examples/digits.in
+%%DATADIR%%/Examples/digits2.ex
+%%DATADIR%%/Examples/encoder.dense.ex
+%%DATADIR%%/Examples/encoder.in
+%%DATADIR%%/Examples/encoder.sparse.ex
+%%DATADIR%%/Examples/filler-srbptt.in
+%%DATADIR%%/Examples/filler.ex.gz
+%%DATADIR%%/Examples/filler.gen
+%%DATADIR%%/Examples/filler.in
+%%DATADIR%%/Examples/formatSentence
+%%DATADIR%%/Examples/hand-digits.in
+%%DATADIR%%/Examples/hand-digits.trn.bex.gz
+%%DATADIR%%/Examples/hand-digits.tst.bex.gz
+%%DATADIR%%/Examples/integrate.in
+%%DATADIR%%/Examples/jets-n-sharks.ex
+%%DATADIR%%/Examples/jets-n-sharks.in
+%%DATADIR%%/Examples/kohonen.ex
+%%DATADIR%%/Examples/kohonen.in
+%%DATADIR%%/Examples/kohonen.tcl
+%%DATADIR%%/Examples/logic.ex.gz
+%%DATADIR%%/Examples/logic.gen
+%%DATADIR%%/Examples/logic.in
+%%DATADIR%%/Examples/logic2.gen
+%%DATADIR%%/Examples/logic2.in
+%%DATADIR%%/Examples/logic2.trn.ex.gz
+%%DATADIR%%/Examples/logic2.tst.ex.gz
+%%DATADIR%%/Examples/negation.ex
+%%DATADIR%%/Examples/negation.in
+%%DATADIR%%/Examples/on-off.ex
+%%DATADIR%%/Examples/on-off.in
+%%DATADIR%%/Examples/on-off2.ex
+%%DATADIR%%/Examples/output
+%%DATADIR%%/Examples/pick-one.ex.gz
+%%DATADIR%%/Examples/pick-one.in
+%%DATADIR%%/Examples/rand10x40.ex
+%%DATADIR%%/Examples/rand10x40.in
+%%DATADIR%%/Examples/rand10x40b.ex
+%%DATADIR%%/Examples/recoder.ex
+%%DATADIR%%/Examples/recoder.gen
+%%DATADIR%%/Examples/recoder.in
+%%DATADIR%%/Examples/rhw-sequence.gen
+%%DATADIR%%/Examples/rhw-sequence.in
+%%DATADIR%%/Examples/rhw-sequence.trn.ex
+%%DATADIR%%/Examples/rhw-sequence.tst.ex
+%%DATADIR%%/Examples/sequence
+%%DATADIR%%/Examples/sequence.ex
+%%DATADIR%%/Examples/sequence.gen
+%%DATADIR%%/Examples/sequence.in
+%%DATADIR%%/Examples/server.tcl
+%%DATADIR%%/Examples/t-c.ex.gz
+%%DATADIR%%/Examples/t-c.gen
+%%DATADIR%%/Examples/t-c.in
+%%DATADIR%%/Examples/task.ex
+%%DATADIR%%/Examples/task.gen
+%%DATADIR%%/Examples/task.in
+%%DATADIR%%/Examples/xor.chooseEx
+%%DATADIR%%/Examples/xor.ex
+%%DATADIR%%/Examples/xor.in
+%%DATADIR%%/Src/Images/down.xbm
+%%DATADIR%%/Src/Images/left.xbm
+%%DATADIR%%/Src/Images/left0.xbm
+%%DATADIR%%/Src/Images/left2.xbm
+%%DATADIR%%/Src/Images/left3.xbm
+%%DATADIR%%/Src/Images/lens.medium.gif
+%%DATADIR%%/Src/Images/lensIcon.gif
+%%DATADIR%%/Src/Images/reload.xbm
+%%DATADIR%%/Src/Images/right.xbm
+%%DATADIR%%/Src/Images/right0.xbm
+%%DATADIR%%/Src/Images/right2.xbm
+%%DATADIR%%/Src/Images/right2b.xbm
+%%DATADIR%%/Src/Images/right3.xbm
+%%DATADIR%%/Src/Images/right3b.xbm
+%%DATADIR%%/Src/Images/up.xbm
+%%DATADIR%%/Src/Images/up2.xbm
+%%DATADIR%%/Src/Images/up3.xbm
+%%DATADIR%%/Src/auto.tcl
+%%DATADIR%%/Src/console.tcl
+%%DATADIR%%/Src/display.tcl
+%%DATADIR%%/Src/file.tcl
+%%DATADIR%%/Src/fileselect.tcl
+%%DATADIR%%/Src/graph.tcl
+%%DATADIR%%/Src/init.tcl
+%%DATADIR%%/Src/interface.tcl
+%%DATADIR%%/Src/lensrc.tcl
+%%DATADIR%%/Src/object.tcl
+%%DATADIR%%/Src/shell.tcl
+@dirrm %%DATADIR%%/Src/Images
+@dirrm %%DATADIR%%/Src
+@dirrm %%DATADIR%%/Examples
+@dirrm %%DATADIR%%/Commands
+@dirrm %%DATADIR%%