aboutsummaryrefslogtreecommitdiffstats
path: root/math/libflame/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /math/libflame/Makefile
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'math/libflame/Makefile')
-rw-r--r--math/libflame/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/libflame/Makefile b/math/libflame/Makefile
index 3bcbfe988305..e2f374398940 100644
--- a/math/libflame/Makefile
+++ b/math/libflame/Makefile
@@ -86,7 +86,7 @@ WITH_BLAS= gotoblas
CONFIGURE_ARGS+= --disable-goto-interfaces
.for b in M K N
.if defined(${b}_BLOCKSIZE)
-CONFIGURE_ARGS+= --enable-default-${b:L}-blocksize=${${b}_BLOCKSIZE}
+CONFIGURE_ARGS+= --enable-default-${b:tl}-blocksize=${${b}_BLOCKSIZE}
.endif
.endfor
.endif
@@ -295,7 +295,7 @@ post-configure:
do-build:
.for o in SHARED STATIC
.if ${PORT_OPTIONS:M${o}}
- @${PRINTF} "\n\n\n===> Building ${o:L} library:\n\n\n\n"
+ @${PRINTF} "\n\n\n===> Building ${o:tl} library:\n\n\n\n"
@cd ${WRKSRC}${o:S|^|_|:M*STATIC}; ${SETENV} ${MAKE_ENV} ${GMAKE} \
${_MAKE_JOBS} ${MAKE_ARGS} libs
.endif
@@ -331,7 +331,7 @@ check regression-test test: build
install-headers
.for o in SHARED STATIC
.if ${PORT_OPTIONS:M${o}}
- @${PRINTF} "\n\n\n===> Testing ${o:L} library:\n\n\n\n"
+ @${PRINTF} "\n\n\n===> Testing ${o:tl} library:\n\n\n\n"
@cd ${WRKSRC}${o:S|^|_|:M*STATIC}/test; ${SETENV} ${MAKE_ENV} \
${GMAKE} ${_MAKE_JOBS} ${MAKE_ARGS} \
LIBBLAS="-L${LOCALBASE}/lib ${BLAS} -lm" \