aboutsummaryrefslogtreecommitdiffstats
path: root/math/libqalculate
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
commitb20f32bb38994e1bb5de05cecc229f10659e0f49 (patch)
treec350c4abc20ce22bda0b7dba0636816742669bc8 /math/libqalculate
parent20be128769eb36776631a3639656f9528820a14c (diff)
downloadfreebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.gz
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.zst
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.zip
- Set CPPFLAGS and LIBS in a number of ports so configure can find libintl.h
and libintl.so. This fixes a problem where DATADIRNAME gets an incorrect value which causes locale files to be installed in the wrong place. - The only configure checks that still need to be patched are related to intltool so move DATADIRNAME patching from USES=pathfix to USE_GNOME=intlhack. - games/klavaro: remove excessive dependencies - japanese/libskk: add INSTALL_TARGET=install-strip - math/libqalculate: add INSTALL_TARGET=install-strip and remove pthread patching - multimedia/freetuxtv: remove excessive dependencies - science/gramps: fix shared-mime-info use Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'math/libqalculate')
-rw-r--r--math/libqalculate/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 4a5b588abcac..574c706897d1 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -13,15 +13,17 @@ COMMENT= Multi-purpose desktop calculator (backend library)
LIB_DEPENDS= libcln.so:${PORTSDIR}/math/cln
USES= pkgconfig pathfix gmake libtool
-USE_GNOME= glib20 intlhack libxml2
+USE_GNOME= glib20 intltool libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USES= gettext
-NLS_CONFIGURE_ENV= GMSGFMT="${LOCALBASE}/bin/msgfmt"
+NLS_USES= gettext
.include <bsd.port.options.mk>
@@ -30,11 +32,5 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.in
.endif
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT} \
- ${WRKSRC}/libqalculate.pc.in
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libqalculate.so*
.include <bsd.port.mk>