aboutsummaryrefslogtreecommitdiffstats
path: root/math/libtsnnls
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
committertijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
commitf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /math/libtsnnls
parente04e533cf1bc01e44ad69d14d5c6c205e25bfe3a (diff)
downloadfreebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.gz
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.zst
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'math/libtsnnls')
-rw-r--r--math/libtsnnls/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/libtsnnls/Makefile b/math/libtsnnls/Makefile
index 52ebacffe2d7..a8e3de0dced2 100644
--- a/math/libtsnnls/Makefile
+++ b/math/libtsnnls/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= tzhuan@gmail.com
COMMENT= Fast Sparse Nonnegative Least Squares Solver
GNU_CONFIGURE= yes
-USE_FORTRAN= yes
+USES= fortran
USE_LDCONFIG= yes
OPTIONS_DEFINE= GOTOBLAS ATLAS
@@ -50,6 +50,7 @@ BLAS=-lptf77blas
LAPACK=-lalapack -lptcblas
.endif
-CONFIGURE_ARGS= --with-blas="${BLAS}" --with-lapack="${LAPACK}"
+CONFIGURE_ARGS+=--with-blas="${BLAS}" --with-lapack="${LAPACK}"
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>