aboutsummaryrefslogtreecommitdiffstats
path: root/math/linalg/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-04-07 09:47:51 +0800
committerwill <will@FreeBSD.org>2000-04-07 09:47:51 +0800
commitea89f63044f006d03e55589702fea4acd1697f06 (patch)
tree82e6cc3cdadcdc5d1f484e5baf1438b220091931 /math/linalg/Makefile
parentdb9cb7494c874692172f27b8a85de71558eb42aa (diff)
downloadfreebsd-ports-gnome-ea89f63044f006d03e55589702fea4acd1697f06.tar.gz
freebsd-ports-gnome-ea89f63044f006d03e55589702fea4acd1697f06.tar.zst
freebsd-ports-gnome-ea89f63044f006d03e55589702fea4acd1697f06.zip
Add LinAlg, an extended C++ math library. Unfortunately, it can't be made
to respect C(C,XX) or C(XX)FLAGS, according to the author. Author also requested that the distfile be hosted on *.FreeBSD.org. PR: 13124 Submitted by: Oleg <oleg@pobox.com>
Diffstat (limited to 'math/linalg/Makefile')
-rw-r--r--math/linalg/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/math/linalg/Makefile b/math/linalg/Makefile
new file mode 100644
index 000000000000..cee7161e056b
--- /dev/null
+++ b/math/linalg/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: LinAlg
+# Version required: 4.3
+# Date created: August 25, 1999
+# Whom: Oleg Kiselyov <oleg@pobox.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= linalg-4.3
+CATEGORIES= math
+MASTER_SITES= http://people.FreeBSD.org/~will/distfiles/
+
+MAINTAINER= oleg@pobox.com
+
+WRKSRC= ${WRKDIR}/LinAlg
+ALL_TARGET= lib
+INSTALL_TARGET= lib
+USE_GMAKE= yes
+
+post-install:
+ $(INSTALL_DATA) ${WRKSRC}/libla.a ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/LinAlg.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/LAStreams.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/builtin.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/math_num.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/minmax.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/myenv.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/std.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/svd.h ${PREFIX}/include/LinAlg
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/LinAlg
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/LinAlg
+.endif
+
+.include <bsd.port.mk>