aboutsummaryrefslogtreecommitdiffstats
path: root/math/mkl-dnn/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-05 08:38:30 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-05 08:38:30 +0800
commit84d7d93be3b11331c0d2c1b1e75391f59c59c0f4 (patch)
treec3bf774bf13dc79419ca0e705ec31065ba77c940 /math/mkl-dnn/Makefile
parent0440aafd1fe32b52a1370661a8f5ffe7682a18ba (diff)
downloadfreebsd-ports-gnome-84d7d93be3b11331c0d2c1b1e75391f59c59c0f4.tar.gz
freebsd-ports-gnome-84d7d93be3b11331c0d2c1b1e75391f59c59c0f4.tar.zst
freebsd-ports-gnome-84d7d93be3b11331c0d2c1b1e75391f59c59c0f4.zip
New port: math/mkl-dnn: Intel(R) Math Kernel Library for Deep Neural Networks
Diffstat (limited to 'math/mkl-dnn/Makefile')
-rw-r--r--math/mkl-dnn/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/math/mkl-dnn/Makefile b/math/mkl-dnn/Makefile
new file mode 100644
index 000000000000..ad86e7bab84a
--- /dev/null
+++ b/math/mkl-dnn/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= mkl-dnn
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.16
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Intel(R) Math Kernel Library for Deep Neural Networks
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BROKEN_FreeBSD_10= invalid value 'internal' in '-fvisibility internal'
+
+TEST_DEPENDS= bash:shells/bash
+
+USES= cmake:outsource compiler:c++11-lib
+USE_GITHUB= yes
+GH_ACCOUNT= intel
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/mkldnn.h \
+ include/mkldnn.hpp \
+ include/mkldnn_debug.h \
+ include/mkldnn_types.h \
+ lib/libmkldnn.so \
+ lib/libmkldnn.so.0 \
+ lib/libmkldnn.so.0.16.0
+
+do-test:
+ @${REINPLACE_CMD} 's| /bin/bash | ${LOCALBASE}/bin/bash |' ${WRKSRC}/tests/CMakeLists.txt
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTS=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>