aboutsummaryrefslogtreecommitdiffstats
path: root/math/ndiff/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-12-16 15:08:25 +0800
committerglewis <glewis@FreeBSD.org>2004-12-16 15:08:25 +0800
commit619b0743201a7bf9577a67587a3b5ecb415c23b6 (patch)
tree45e33276df9593c398146dcd084db6a47a9f87f8 /math/ndiff/Makefile
parenta6922bd6691408b4518c0563532a5633dd96d541 (diff)
downloadfreebsd-ports-gnome-619b0743201a7bf9577a67587a3b5ecb415c23b6.tar.gz
freebsd-ports-gnome-619b0743201a7bf9577a67587a3b5ecb415c23b6.tar.zst
freebsd-ports-gnome-619b0743201a7bf9577a67587a3b5ecb415c23b6.zip
. Respect hier(7).
. Use a better ALL_TARGET. Having check as part of it tried to install some files. Use check-runs to achieve the desired testing without doing any installation. . ${INSTALL_MAN} -> ${INSTALL_DATA} for doc installation (they aren't manual pages).
Diffstat (limited to 'math/ndiff/Makefile')
-rw-r--r--math/ndiff/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/math/ndiff/Makefile b/math/ndiff/Makefile
index 5801a223f881..16aefc9f3366 100644
--- a/math/ndiff/Makefile
+++ b/math/ndiff/Makefile
@@ -33,14 +33,18 @@ CONFIGURE_ARGS= --with-double
.endif
.endif
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-ALL_TARGET= all check
+ALL_TARGET= all check-runs
MAN1= ndiff.1
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s:%%DATADIR%%:${DATADIR}:g" ${WRKSRC}/Makefile.in
+
post-build:
@${ECHO_MSG} "If there were no errors in the above checks then type"
@${ECHO_MSG}
@@ -51,9 +55,9 @@ post-build:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.pdf ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.ps ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.ps ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
.endif
.include <bsd.port.post.mk>