aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave-forge-octproj
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-06-29 19:53:37 +0800
committersylvio <sylvio@FreeBSD.org>2010-06-29 19:53:37 +0800
commit08012874eff015618d66a51d01b704bf47515759 (patch)
tree083d34969cd9be30a532e4a64bd53bb63f0b1540 /math/octave-forge-octproj
parent01f6bdfee4318cb844dba219b31874a9200daaff (diff)
downloadfreebsd-ports-gnome-08012874eff015618d66a51d01b704bf47515759.tar.gz
freebsd-ports-gnome-08012874eff015618d66a51d01b704bf47515759.tar.zst
freebsd-ports-gnome-08012874eff015618d66a51d01b704bf47515759.zip
The octave-forge package is the result of the GNU Octave Repositry Project, which is intended to be a central location for custom scripts, functions plus build and install scripts.
This is octproj. This package allows to call functions of PROJ.4 library for cartographic projections transformations. WWW: http://octave.sourceforge.net/ PR: ports/147517 Submitted by: Stephen Montgomery-Smith <stephen@missouri.edu> Feature safe: yes
Diffstat (limited to 'math/octave-forge-octproj')
-rw-r--r--math/octave-forge-octproj/Makefile24
-rw-r--r--math/octave-forge-octproj/distinfo3
-rw-r--r--math/octave-forge-octproj/files/patch-src_Makefile32
-rw-r--r--math/octave-forge-octproj/pkg-descr11
-rw-r--r--math/octave-forge-octproj/pkg-plist1
5 files changed, 71 insertions, 0 deletions
diff --git a/math/octave-forge-octproj/Makefile b/math/octave-forge-octproj/Makefile
new file mode 100644
index 000000000000..4d8f8b998904
--- /dev/null
+++ b/math/octave-forge-octproj/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: octave-forge-octproj
+# Date created: 5 June 2010
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-octproj
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+
+LIB_DEPENDS+= proj:${PORTSDIR}/graphics/proj
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-octproj/distinfo b/math/octave-forge-octproj/distinfo
new file mode 100644
index 000000000000..e1ec37693cc7
--- /dev/null
+++ b/math/octave-forge-octproj/distinfo
@@ -0,0 +1,3 @@
+MD5 (octave-forge/octproj-1.0.0.tar.gz) = a78cc542dd94370de10108c755cf5ed1
+SHA256 (octave-forge/octproj-1.0.0.tar.gz) = 1c69fd45d48385c790d25537b2c472d7aa0327981721da1cf8d1b7f3aeee6bb4
+SIZE (octave-forge/octproj-1.0.0.tar.gz) = 222454
diff --git a/math/octave-forge-octproj/files/patch-src_Makefile b/math/octave-forge-octproj/files/patch-src_Makefile
new file mode 100644
index 000000000000..d9fd05207931
--- /dev/null
+++ b/math/octave-forge-octproj/files/patch-src_Makefile
@@ -0,0 +1,32 @@
+--- Makefile.orig 2010-02-15 02:08:22.000000000 -0600
++++ Makefile 2010-06-05 19:27:12.000000000 -0500
+@@ -1,16 +1,23 @@
+-.PHONY: all
+-all: compile clean
++all: _op_transform.oct _op_fwd.oct _op_inv.oct _op_geod2geoc.oct _op_geoc2geod.oct
+
+-.PHONY: compile
+-compile:
+- cc -c -O3 -Wall -Wextra projwrap.c -o projwrap.o
++projwrap.o:
++ ${CC} ${CFLAGS} -fPIC -c -O3 -Wall -Wextra projwrap.c -o projwrap.o
++
++_op_transform.oct: _op_transform.cc projwrap.o
+ mkoctfile -s -Wall -Wextra _op_transform.cc projwrap.o -lproj
++
++_op_fwd.oct: _op_fwd.cc projwrap.o
+ mkoctfile -s -Wall -Wextra _op_fwd.cc projwrap.o -lproj
++
++_op_inv.oct: _op_inv.cc projwrap.o
+ mkoctfile -s -Wall -Wextra _op_inv.cc projwrap.o -lproj
++
++_op_geod2geoc.oct: _op_geod2geoc.cc
+ mkoctfile -s -Wall -Wextra _op_geod2geoc.cc -lproj
++
++_op_geoc2geod.oct: _op_geoc2geod.cc
+ mkoctfile -s -Wall -Wextra _op_geoc2geod.cc -lproj
+
+-.PHONY: clean
+ clean:
+ rm _op_transform.o _op_fwd.o _op_inv.o _op_geod2geoc.o _op_geoc2geod.o
+ rm projwrap.o
diff --git a/math/octave-forge-octproj/pkg-descr b/math/octave-forge-octproj/pkg-descr
new file mode 100644
index 000000000000..9f10c1e8d8e0
--- /dev/null
+++ b/math/octave-forge-octproj/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is octproj.
+
+This package allows to call functions of PROJ.4 library for cartographic
+projections transformations.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-octproj/pkg-plist b/math/octave-forge-octproj/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-octproj/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty