aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave-forge-video
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-02-10 20:32:02 +0800
committerpav <pav@FreeBSD.org>2009-02-10 20:32:02 +0800
commit4d51d28233aacb452108ff8f81809021672d6fdc (patch)
tree7487410dcb777c75e6f6b9164799000e07eb3dc7 /math/octave-forge-video
parent37887eea138259e6beea923fc78b12db3e4111e9 (diff)
downloadfreebsd-ports-gnome-4d51d28233aacb452108ff8f81809021672d6fdc.tar.gz
freebsd-ports-gnome-4d51d28233aacb452108ff8f81809021672d6fdc.tar.zst
freebsd-ports-gnome-4d51d28233aacb452108ff8f81809021672d6fdc.zip
- Fix build with gcc43
- While here, style Submitted by: Stephen Montgomery-Smith <stephen@math.missouri.edu> (maintainer)
Diffstat (limited to 'math/octave-forge-video')
-rw-r--r--math/octave-forge-video/Makefile4
-rw-r--r--math/octave-forge-video/files/patch-AVHandler.cc10
2 files changed, 12 insertions, 2 deletions
diff --git a/math/octave-forge-video/Makefile b/math/octave-forge-video/Makefile
index 62ccea8483b7..00487a11b375 100644
--- a/math/octave-forge-video/Makefile
+++ b/math/octave-forge-video/Makefile
@@ -7,10 +7,10 @@
PORTNAME= octave-forge-video
PORTVERSION= 1.0.1
-CATEGORIES= math
+CATEGORIES= math
MAINTAINER= stephen@math.missouri.edu
-COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
diff --git a/math/octave-forge-video/files/patch-AVHandler.cc b/math/octave-forge-video/files/patch-AVHandler.cc
new file mode 100644
index 000000000000..22dbe5908863
--- /dev/null
+++ b/math/octave-forge-video/files/patch-AVHandler.cc
@@ -0,0 +1,10 @@
+--- src/AVHandler.cc.orig 2008-08-24 18:14:47.000000000 +0200
++++ src/AVHandler.cc 2009-02-10 09:15:25.000000000 +0100
+@@ -24,6 +24,7 @@
+
+ #include "AVHandler.h"
+
++#include <stdlib.h>
+ #include <string>
+
+ #ifdef _MSC_VER