aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-GIS-Distance/Makefile
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-30 13:00:28 +0800
committerrafan <rafan@FreeBSD.org>2008-03-30 13:00:28 +0800
commitc193e24933932c1b882e418238457ff2f1f24ea3 (patch)
treee94dbb0feea5cd83ba73a43a54728a2506a88dc6 /math/p5-GIS-Distance/Makefile
parent06b3fda756774f73155128d25b9c39a1ef006a5a (diff)
downloadfreebsd-ports-gnome-c193e24933932c1b882e418238457ff2f1f24ea3.tar.gz
freebsd-ports-gnome-c193e24933932c1b882e418238457ff2f1f24ea3.tar.zst
freebsd-ports-gnome-c193e24933932c1b882e418238457ff2f1f24ea3.zip
- Update to 0.02
- Pass to perl@ PR: ports/122028 Submitted by: Gea-Suan Lin <gslin at gslin.org> (maintainer)
Diffstat (limited to 'math/p5-GIS-Distance/Makefile')
-rw-r--r--math/p5-GIS-Distance/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/math/p5-GIS-Distance/Makefile b/math/p5-GIS-Distance/Makefile
index 6c7ad13a5a92..3b3c2585aafc 100644
--- a/math/p5-GIS-Distance/Makefile
+++ b/math/p5-GIS-Distance/Makefile
@@ -6,23 +6,30 @@
#
PORTNAME= GIS-Distance
-PORTVERSION= 0.01001
-CATEGORIES= math
+PORTVERSION= 0.02
+PORTEPOCH= 1
+CATEGORIES= math perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/B/BL/BLUEFEET
PKGNAMEPREFIX= p5-
-MAINTAINER= gslin@gslin.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Calculate geographic distances
RUN_DEPENDS= ${SITE_PERL}/Class/Data/Accessor.pm:${PORTSDIR}/devel/p5-Class-Data-Accessor \
- ${SITE_PERL}/Class/Measure.pm:${PORTSDIR}/devel/p5-Class-Measure
+ ${SITE_PERL}/Class/Measure.pm:${PORTSDIR}/devel/p5-Class-Measure \
+ ${SITE_PERL}/Moose.pm:${PORTSDIR}/devel/p5-Moose
PERL_CONFIGURE= yes
-MAN3= GIS::Distance.3 GIS::Distance::Cosine.3 \
- GIS::Distance::GeoEllipsoid.3 GIS::Distance::GreatCircle.3 \
- GIS::Distance::Haversine.3 GIS::Distance::MathTrig.3 \
- GIS::Distance::Polar.3 GIS::Distance::Vincenty.3
+MAN3= GIS::Distance.3 \
+ GIS::Distance::Formula.3 \
+ GIS::Distance::Formula::Cosine.3 \
+ GIS::Distance::Formula::GeoEllipsoid.3 \
+ GIS::Distance::Formula::GreatCircle.3 \
+ GIS::Distance::Formula::Haversine.3 \
+ GIS::Distance::Formula::MathTrig.3 \
+ GIS::Distance::Formula::Polar.3 \
+ GIS::Distance::Formula::Vincenty.3
.include <bsd.port.mk>