aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Random
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-07 00:30:40 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-07 00:30:40 +0800
commit03c703c8959aaf4b2798aa9f43bb22e98e2f8b78 (patch)
treee8ce288d93bde5d2bd3dde8a6558dd1c21ad6e5a /math/p5-Math-Random
parent0260b08549e77ef4e16cb6d6945a7f2b65a037c6 (diff)
downloadfreebsd-ports-gnome-03c703c8959aaf4b2798aa9f43bb22e98e2f8b78.tar.gz
freebsd-ports-gnome-03c703c8959aaf4b2798aa9f43bb22e98e2f8b78.tar.zst
freebsd-ports-gnome-03c703c8959aaf4b2798aa9f43bb22e98e2f8b78.zip
add p5-Math-Random
Random number generators PR: 28715 Submitted by: Sergey Skvortsov <skv@protey.ru>
Diffstat (limited to 'math/p5-Math-Random')
-rw-r--r--math/p5-Math-Random/Makefile22
-rw-r--r--math/p5-Math-Random/distinfo1
-rw-r--r--math/p5-Math-Random/pkg-comment1
-rw-r--r--math/p5-Math-Random/pkg-descr2
-rw-r--r--math/p5-Math-Random/pkg-plist8
5 files changed, 34 insertions, 0 deletions
diff --git a/math/p5-Math-Random/Makefile b/math/p5-Math-Random/Makefile
new file mode 100644
index 000000000000..307015e59937
--- /dev/null
+++ b/math/p5-Math-Random/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Math::Random
+# Date created: 5 Jul 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Random
+PORTVERSION= 0.61
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Random.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Random/distinfo b/math/p5-Math-Random/distinfo
new file mode 100644
index 000000000000..7f414e5f5eb8
--- /dev/null
+++ b/math/p5-Math-Random/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Random-0.61.tar.gz) = 844197763ebc45669841bf8700f85f44
diff --git a/math/p5-Math-Random/pkg-comment b/math/p5-Math-Random/pkg-comment
new file mode 100644
index 000000000000..4fdec8d70c28
--- /dev/null
+++ b/math/p5-Math-Random/pkg-comment
@@ -0,0 +1 @@
+Random number generators
diff --git a/math/p5-Math-Random/pkg-descr b/math/p5-Math-Random/pkg-descr
new file mode 100644
index 000000000000..361793cfb5f5
--- /dev/null
+++ b/math/p5-Math-Random/pkg-descr
@@ -0,0 +1,2 @@
+Math::Random is a Perl port of the C version of randlib,
+which is a suite of routines for generating random deviates.
diff --git a/math/p5-Math-Random/pkg-plist b/math/p5-Math-Random/pkg-plist
new file mode 100644
index 000000000000..8ede4f652fd8
--- /dev/null
+++ b/math/p5-Math-Random/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Random/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/Random.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/example.pl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Random/Random.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Random/Random.so
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Random 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true