aboutsummaryrefslogtreecommitdiffstats
path: root/math/plplot/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-10 23:39:09 +0800
committerkrion <krion@FreeBSD.org>2004-02-10 23:39:09 +0800
commitec06c7d44a3649f6cb8bdcfc23345c8cdfc53740 (patch)
treeb56f2e41bbb08b99d63a5c292bafbc73786883ea /math/plplot/Makefile
parentf7bd3257c4ff2a11afd70ba09a00d4db217b77cf (diff)
downloadfreebsd-ports-gnome-ec06c7d44a3649f6cb8bdcfc23345c8cdfc53740.tar.gz
freebsd-ports-gnome-ec06c7d44a3649f6cb8bdcfc23345c8cdfc53740.tar.zst
freebsd-ports-gnome-ec06c7d44a3649f6cb8bdcfc23345c8cdfc53740.zip
- Update to version 5.3.0
PR: ports/62641 Submitted by: Ports Fury
Diffstat (limited to 'math/plplot/Makefile')
-rw-r--r--math/plplot/Makefile51
1 files changed, 44 insertions, 7 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 3fc081d657c2..b3bf3d02cbe0 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= plplot
-PORTVERSION= 5.2.1
-PORTREVISION= 2
+PORTVERSION= 5.3.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,9 +15,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A scientific plotting package
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl \
+ gd.4:${PORTSDIR}/graphics/gd
-USE_GNOME= gnomehack pkgconfig
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -27,7 +26,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GDINCDIR="${LOCALBASE}/include" \
GDLIBDIR="${LOCALBASE}/lib" \
M4="${LOCALBASE}/bin/gm4"
-CONFIGURE_ARGS= --disable-python --disable-octave --without-qhull
+CONFIGURE_ARGS= --disable-cgm --disable-java --disable-octave \
+ --with-ltdlsystem --without-qhull
INSTALLS_SHLIB= yes
PLIST_SUB= VERSION="${PORTVERSION}"
@@ -42,6 +42,18 @@ USE_XLIB= yes
PLIST_SUB+= X11=""
.endif
+.if !defined(WITHOUT_PTHREAD)
+CONFIGURE_ARGS+= --with-pthreads
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
.if defined(WITH_TCLTK)
.undef WITHOUT_X11
PKGNAMESUFFIX= -tcltk
@@ -63,12 +75,37 @@ CONFIGURE_ARGS+= --disable-itcl --disable-tcl --disable-tk
PLIST_SUB+= TCLTK="@comment "
.endif
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "PLplot has the following tunable options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_X11=yes Turns off X11 support"
+ @${ECHO_MSG} " WITHOUT_PTHREAD=yes Turns off pthread support"
+ @${ECHO_MSG} " WITH_PYTHON=yes Turns on Python support"
+ @${ECHO_MSG} " WITH_TCLTK=yes Turns on Tcl/Tk support"
+ @${ECHO_MSG} ""
+
post-patch:
@${REINPLACE_CMD} -e 's|-litk$$|-litk32|g ; \
s|-ltk$$|-ltk83|g ; \
s|-litcl$$|-litcl32|g ; \
- s|-ltcl$$|-ltcl83|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|tclsh|${LOCALBASE}/bin/tclsh8.3|g' \
+ s|-ltcl$$|-ltcl83|g ; \
+ s|-lpthread|${PTHREAD_LIBS:S/"//g}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| tclsh | ${LOCALBASE}/bin/tclsh8.3 |g' \
${WRKSRC}/scripts/mktclIndex
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS ChangeLog Copyright FAQ NEWS PROBLEMS README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/drivers/README.drivers \
+ ${DOCSDIR}/README.drivers
+ ${INSTALL_DATA} ${WRKSRC}/lib/csa/README \
+ ${DOCSDIR}/README.csa
+ ${INSTALL_DATA} ${WRKSRC}/lib/csa/README.1st \
+ ${DOCSDIR}/README.1st.csa
+.endif
+
.include <bsd.port.mk>