aboutsummaryrefslogtreecommitdiffstats
path: root/math/plplot
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-12-30 19:26:21 +0800
committerthierry <thierry@FreeBSD.org>2009-12-30 19:26:21 +0800
commitd94abab13898dc13cff3b63b1e0ef1a525ef0df0 (patch)
tree0d9a2e61b44bea374148cd63ac91fe3c698991f6 /math/plplot
parent8d015c1df048f5de16d5874233e0577928c812c2 (diff)
downloadfreebsd-ports-gnome-d94abab13898dc13cff3b63b1e0ef1a525ef0df0.tar.gz
freebsd-ports-gnome-d94abab13898dc13cff3b63b1e0ef1a525ef0df0.tar.zst
freebsd-ports-gnome-d94abab13898dc13cff3b63b1e0ef1a525ef0df0.zip
Fix for the case WITHOUT_X11.
Notified by: Pedro F. Giffuni <giffunip (at) yahoo.com>
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile6
-rw-r--r--math/plplot/pkg-plist2
2 files changed, 5 insertions, 3 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 7022dd907408..17c959c706aa 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -28,7 +28,6 @@ USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOME= pango
USE_GHOSTSCRIPT=yes
-GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
WITH_FREETYPE=ON
@@ -46,7 +45,6 @@ CMAKE_ARGS+= -DTHREADS_HAVE_PTHREAD_ARG:BOOL=OFF
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
-CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11="@comment "
.else
USE_XORG= x11
@@ -121,6 +119,10 @@ pre-everything::
pre-configure:
${REINPLACE_CMD} -e 's|/usr/share/fonts/truetype/freefont|${LOCALBASE}/lib/X11/fonts/freefont-ttf|'\
${WRKSRC}/cmake/modules/freetype.cmake
+.if defined(WITHOUT_X11)
+ ${REINPLACE_CMD} -e 's|^find_package(X11)|SET(X11_FOUND "FALSE")|' \
+ ${WRKSRC}/cmake/modules/plplot.cmake
+.endif
.if defined(WITH_TCLTK)
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|; \
s|/usr/include|${LOCALBASE}/include|' \
diff --git a/math/plplot/pkg-plist b/math/plplot/pkg-plist
index 11a77f8d777a..d6483b75df44 100644
--- a/math/plplot/pkg-plist
+++ b/math/plplot/pkg-plist
@@ -144,7 +144,7 @@ libdata/pkgconfig/plplotd.pc
%%DATADIR%%/examples/c/Makefile
%%DATADIR%%/examples/c/README.cairo
%%DATADIR%%/examples/c/ext-cairo-test.c
-%%DATADIR%%/examples/c/extXdrawable_demo.c
+%%X11%%%%DATADIR%%/examples/c/extXdrawable_demo.c
%%DATADIR%%/examples/c/plcdemos.h
%%DATADIR%%/examples/c/test_plend.c
%%DATADIR%%/examples/c/tutor.c