aboutsummaryrefslogtreecommitdiffstats
path: root/math/pure-mpfr/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2012-01-27 04:18:32 +0800
committerpav <pav@FreeBSD.org>2012-01-27 04:18:32 +0800
commit91fb36a495befc14c051a13821b6c601227465c4 (patch)
tree4ddae3d045f566c8029e850106dfaa4bdef04ad5 /math/pure-mpfr/Makefile
parent2a4113ba8b9262532fc429bdbeb912438381bbf9 (diff)
downloadfreebsd-ports-gnome-91fb36a495befc14c051a13821b6c601227465c4.tar.gz
freebsd-ports-gnome-91fb36a495befc14c051a13821b6c601227465c4.tar.zst
freebsd-ports-gnome-91fb36a495befc14c051a13821b6c601227465c4.zip
- Add a couple of pure extensions:
devel/pure-readline: A readline interface for the Pure language devel/pure-stldict: Pure interface to C++ STL map/unordered_map devel/pure-stlvec: Pure interface to C++ STL vector math/pure-mpfr: Multiprecision floats for Pure x11-toolkits/pure-tk: A basic interface between Pure and Tcl/Tk PR: ports/161799 Submitted by: Zhihao Yuan <lichray@gmail.com>
Diffstat (limited to 'math/pure-mpfr/Makefile')
-rw-r--r--math/pure-mpfr/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
new file mode 100644
index 000000000000..a2979b844843
--- /dev/null
+++ b/math/pure-mpfr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pure-mpfr
+# Date created: 2011-10-19
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-mpfr
+PORTVERSION= 0.4
+CATEGORIES= math
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Multiprecision floats for Pure
+
+USE_PURE= yes
+
+PLIST_FILES= lib/pure/mpfr.pure \
+ lib/pure/mpfr.so
+
+MAKE_ARGS+= libdir="${PREFIX}/lib"
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>