aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-algopy
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-04-18 06:24:52 +0800
committeryuri <yuri@FreeBSD.org>2018-04-18 06:24:52 +0800
commit71d5efe6b705d20a5928a22df3520fe496a6557f (patch)
tree6094911adefcb6f11bea9496bf4938658801d041 /math/py-algopy
parentee871dc01c60d082c14b8403d2775ddb781920ad (diff)
downloadfreebsd-ports-gnome-71d5efe6b705d20a5928a22df3520fe496a6557f.tar.gz
freebsd-ports-gnome-71d5efe6b705d20a5928a22df3520fe496a6557f.tar.zst
freebsd-ports-gnome-71d5efe6b705d20a5928a22df3520fe496a6557f.zip
New port: math/py-algopy: Algorithmic Differentiation (AD) and Taylor polynomial approximations
Diffstat (limited to 'math/py-algopy')
-rw-r--r--math/py-algopy/Makefile20
-rw-r--r--math/py-algopy/distinfo3
-rw-r--r--math/py-algopy/pkg-descr10
3 files changed, 33 insertions, 0 deletions
diff --git a/math/py-algopy/Makefile b/math/py-algopy/Makefile
new file mode 100644
index 000000000000..0bfa25cbb48f
--- /dev/null
+++ b/math/py-algopy/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= algopy
+DISTVERSION= 0.5.7
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Algorithmic Differentiation (AD) and Taylor polynomial approximations
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python zip
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-algopy/distinfo b/math/py-algopy/distinfo
new file mode 100644
index 000000000000..3ff9366933d8
--- /dev/null
+++ b/math/py-algopy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524003219
+SHA256 (algopy-0.5.7.zip) = 6955f676fce3858fa3585cb7f3f7e1796cb93377d24016419b6699291584b7df
+SIZE (algopy-0.5.7.zip) = 189516
diff --git a/math/py-algopy/pkg-descr b/math/py-algopy/pkg-descr
new file mode 100644
index 000000000000..214144cdf392
--- /dev/null
+++ b/math/py-algopy/pkg-descr
@@ -0,0 +1,10 @@
+The purpose of AlgoPy is the evaluation of higher-order derivatives in the
+forward and reverse mode of Algorithmic Differentiation (AD) of functions
+that are implemented as Python programs. Particular focus are functions that
+contain numerical linear algebra functions as they often appear in statistically
+motivated functions. The intended use of AlgoPy is for easy prototyping at
+reasonable execution speeds. More precisely, for a typical program a directional
+derivative takes order 10 times as much time as time as the function evaluation.
+This is approximately also true for the gradient.
+
+WWW: https://pythonhosted.org/algopy/