aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-gato
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /math/py-gato
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'math/py-gato')
-rw-r--r--math/py-gato/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index 791a5b7f6790..d4acdc123fe0 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -24,6 +24,9 @@ WRKSRC= ${WRKDIR}/Gato
GATO_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/Gato
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+post-patch:
+ @ ${REINPLACE_CMD} -e 's,^.*__future__.*$$,,' ${WRKSRC}/DataStructures.py
+
pre-build:
@ ${TOUCH} ${WRKSRC}/__init__.py