aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2011-11-12 02:16:37 +0800
committerrm <rm@FreeBSD.org>2011-11-12 02:16:37 +0800
commitb7fc453e34db1effb55c27439b55e18ac72e9b93 (patch)
tree7682642afcf4bab19b57989da1ee0ea96adf5b84 /math/py-matplotlib
parent256a89a383e775228558e010f12cc21cd96165b3 (diff)
downloadfreebsd-ports-gnome-b7fc453e34db1effb55c27439b55e18ac72e9b93.tar.gz
freebsd-ports-gnome-b7fc453e34db1effb55c27439b55e18ac72e9b93.tar.zst
freebsd-ports-gnome-b7fc453e34db1effb55c27439b55e18ac72e9b93.zip
- fix build on FreeBSD 10
- strict python versions to 2.6-2.7 - bump USE_WX to 2.8+ according to matplotlib docs - fix pkg-plist after switching this port to wxPython 2.8+ - bump PORTREVISION PR: ports/161716 Submitted by: rm (myself) Approved by: Geoffrey Mainland <mainland@apeiron.net> (maintainer), novel (mentor) Feature safe: yes
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile10
-rw-r--r--math/py-matplotlib/files/patch-setupext.py13
-rw-r--r--math/py-matplotlib/pkg-plist1
3 files changed, 10 insertions, 14 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index dbf3ec26ea82..d8efdc916f74 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= matplotlib
PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
-USE_PYTHON= 2.4+
+USE_PYTHON= 2.6-2.7
USE_PYDISTUTILS=yes
CFLAGS+= -I${LOCALBASE}/include
@@ -85,17 +85,13 @@ PLIST_SUB+= TKAGGBACKEND="@comment "
.endif
.if defined(WITH_WXAGGBACKEND)
-USE_WX= 2.6
+USE_WX= 2.8+
WX_COMPS= python
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
WXAGG_BACKEND= True
-
-PLIST_SUB+= WXAGGBACKEND=""
.else
WXAGG_BACKEND= False
-
-PLIST_SUB+= WXAGGBACKEND="@comment "
.endif
.include <bsd.port.pre.mk>
diff --git a/math/py-matplotlib/files/patch-setupext.py b/math/py-matplotlib/files/patch-setupext.py
index 2aa771b7e3cd..8da1504053d5 100644
--- a/math/py-matplotlib/files/patch-setupext.py
+++ b/math/py-matplotlib/files/patch-setupext.py
@@ -1,16 +1,17 @@
---- setupext.py.orig 2010-07-07 09:41:55.000000000 +0800
-+++ setupext.py 2011-06-27 16:14:58.000000000 +0800
-@@ -68,6 +68,9 @@
+--- setupext.py.orig 2010-07-07 05:41:55.000000000 +0400
++++ setupext.py 2011-10-16 18:49:43.000000000 +0400
+@@ -68,6 +68,10 @@
'freebsd4' : ['/usr/local', '/usr'],
'freebsd5' : ['/usr/local', '/usr'],
'freebsd6' : ['/usr/local', '/usr'],
+ 'freebsd7' : ['/usr/local', '/usr'],
+ 'freebsd8' : ['/usr/local', '/usr'],
+ 'freebsd9' : ['/usr/local', '/usr'],
++ 'freebsd10': ['/usr/local', '/usr'],
'sunos5' : [os.getenv('MPLIB_BASE') or '/usr/local',],
'gnukfreebsd5' : ['/usr/local', '/usr'],
'gnukfreebsd6' : ['/usr/local', '/usr'],
-@@ -789,7 +792,7 @@
+@@ -789,7 +793,7 @@
module.libraries.extend(wxlibs)
return
@@ -19,7 +20,7 @@
# Make sure you use the Tk version given by Tkinter.TkVersion
# or else you'll build for a wrong version of the Tcl
-@@ -828,8 +831,12 @@
+@@ -828,8 +832,12 @@
gotit = False
if gotit:
@@ -33,7 +34,7 @@
else:
print_status("Tkinter", "no")
if explanation is not None:
-@@ -1092,9 +1099,9 @@
+@@ -1092,9 +1100,9 @@
# Add final versions of directories and libraries to module lists
tcl_lib, tcl_inc, tk_lib, tk_inc = result
diff --git a/math/py-matplotlib/pkg-plist b/math/py-matplotlib/pkg-plist
index 7e74e0a77043..0fb411b2980d 100644
--- a/math/py-matplotlib/pkg-plist
+++ b/math/py-matplotlib/pkg-plist
@@ -50,7 +50,6 @@
%%GTKBACKEND%%%%PYTHON_SITELIBDIR%%/matplotlib/backends/_backend_gdk.so
%%GTKAGGBACKEND%%%%PYTHON_SITELIBDIR%%/matplotlib/backends/_gtkagg.so
%%TKAGGBACKEND%%%%PYTHON_SITELIBDIR%%/matplotlib/backends/_tkagg.so
-%%WXAGGBACKEND%%%%PYTHON_SITELIBDIR%%/matplotlib/backends/_wxagg.so
%%PYTHON_SITELIBDIR%%/matplotlib/backends/backend_agg.py
%%PYTHON_SITELIBDIR%%/matplotlib/backends/backend_agg.pyc
%%PYTHON_SITELIBDIR%%/matplotlib/backends/backend_agg.pyo