aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-numarray
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2005-11-18 20:50:57 +0800
committerperky <perky@FreeBSD.org>2005-11-18 20:50:57 +0800
commitc18af1d0bf6c4dc7251f648610134a3b27bf8c61 (patch)
tree448bb424a9ce8d1368316a6e63486c692241f899 /math/py-numarray
parent2859c8a64ecf119dfd21fcd8a8d3db4bbecf6096 (diff)
downloadfreebsd-ports-gnome-c18af1d0bf6c4dc7251f648610134a3b27bf8c61.tar.gz
freebsd-ports-gnome-c18af1d0bf6c4dc7251f648610134a3b27bf8c61.tar.zst
freebsd-ports-gnome-c18af1d0bf6c4dc7251f648610134a3b27bf8c61.zip
Add a patch to avoid C++ keyword conflict in a header file.
Spotted by: thierry
Diffstat (limited to 'math/py-numarray')
-rw-r--r--math/py-numarray/Makefile1
-rw-r--r--math/py-numarray/files/patch-Include::numarray::nummacro.h14
2 files changed, 15 insertions, 0 deletions
diff --git a/math/py-numarray/Makefile b/math/py-numarray/Makefile
index 48b89e5fcf9b..886478be2b86 100644
--- a/math/py-numarray/Makefile
+++ b/math/py-numarray/Makefile
@@ -7,6 +7,7 @@
PORTNAME= numarray
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= numpy
diff --git a/math/py-numarray/files/patch-Include::numarray::nummacro.h b/math/py-numarray/files/patch-Include::numarray::nummacro.h
new file mode 100644
index 000000000000..1cb40e378d5f
--- /dev/null
+++ b/math/py-numarray/files/patch-Include::numarray::nummacro.h
@@ -0,0 +1,14 @@
+--- Include/numarray/nummacro.h.orig Fri Nov 18 20:42:15 2005
++++ Include/numarray/nummacro.h Fri Nov 18 20:43:33 2005
+@@ -24,7 +24,11 @@
+ int n_outs, PyObject*outs[]);
+ typedef struct {
+ PyObject_HEAD
++#ifdef __cplusplus
++ PyObject *operator_; /* ufunc name */
++#else
+ PyObject *operator; /* ufunc name */
++#endif
+ PyObject *identity; /* identity value, e.g. 0 for + or 1 for * */
+ int n_inputs, n_outputs;
+ _ufunc_function call;