aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-numpy/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2015-03-09 19:43:11 +0800
committerDmitry Sivachenko <demon@FreeBSD.org>2015-03-09 19:43:11 +0800
commit6cfdba09e53ca6eede0f147f33fc82b75fdce285 (patch)
tree1848902f5c1a2e1864a698fcf0aff4860099d572 /math/py-numpy/Makefile
parent58b74c18e64c0d2c2793ca9354223475b09ce2eb (diff)
downloadfreebsd-ports-gnome-6cfdba09e53ca6eede0f147f33fc82b75fdce285.tar.gz
freebsd-ports-gnome-6cfdba09e53ca6eede0f147f33fc82b75fdce285.tar.zst
freebsd-ports-gnome-6cfdba09e53ca6eede0f147f33fc82b75fdce285.zip
Update to version 1.9.2.
This is minor bugfix release, see notes at http://sourceforge.net/projects/numpy/files/NumPy/1.9.2/
Diffstat (limited to 'math/py-numpy/Makefile')
-rw-r--r--math/py-numpy/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index dbf3a3a4990d..6bf9bbbe81ac 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -2,16 +2,15 @@
# $FreeBSD$
PORTNAME= numpy
-PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTVERSION= 1.9.2
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://docs.scipy.org/doc/${PORTNAME}/:doc \
SF/${PORTNAME}/NumPy/${PORTVERSION}:source
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= numpy-${PORTVERSION:S/r/rc/}${EXTRACT_SUFX}:source \
- numpy-ref-${PORTVERSION}.pdf:doc \
- numpy-user-${PORTVERSION}.pdf:doc
+ numpy-ref-${DOCVERSION}.pdf:doc \
+ numpy-user-${DOCVERSION}.pdf:doc
EXTRACT_ONLY= numpy-${PORTVERSION:S/r/rc/}${EXTRACT_SUFX}
MAINTAINER= python@FreeBSD.org
@@ -35,6 +34,7 @@ PYDISTUTILS_BUILDARGS+= --fcompiler=gnu95
PORTDOCS= *
WRKSRC= ${WRKDIR}/${DISTNAME:S/r/rc/}
+DOCVERSION= 1.9.1
ATLAS_LIB_DEPENDS= libatlas.so:${PORTSDIR}/math/atlas
ATLAS_LIB_DEPENDS_OFF= libblas.so:${PORTSDIR}/math/blas \
@@ -74,7 +74,7 @@ post-install:
${LN} -sf ${MANPREFIX}/man/man1/f2py-${PYTHON_VER}.1 ${STAGEDIR}${MANPREFIX}/man/man1/f2py.1
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/numpy-ref-${PORTVERSION}.pdf ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/numpy-user-${PORTVERSION}.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/numpy-ref-${DOCVERSION}.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/numpy-user-${DOCVERSION}.pdf ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
1-11/+0 * Bump PORTREVISION after KDE SC update.Max Brazhnikov2013-02-041-1/+1 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!Max Brazhnikov2013-02-043-23/+16 * Bump PORTREVISON after devel/py-sip and devel/qscintilla2 update.Max Brazhnikov2013-02-041-1/+1 * - Add LICENSE.Hiroki Sato2013-02-031-7/+5 * - Fix all cases of 'No newline at end of file' in ports treeAlex Kozlov2013-02-013-3/+3 * - revert conversion of WITH_DEBUG (handled by bpm)Jason Helfman2013-02-011-2/+2 * - update to 2.5Jason Helfman2013-02-013-11/+11 * Revert a commit that should not have happenedBaptiste Daroussin2013-02-011-2/+2 * Chase boost updateBaptiste Daroussin2013-01-315-24/+12 * Update conflicts and avoid duplication.David E. O'Brien2013-01-301-2/+3 * - Fix search on 64-bit systemsDmitry Marakasov2013-01-292-0/+12 * Fix build error when WRKDIRPREFIX is set.MANTANI Nobutaka2013-01-271-9/+9 * Convert Makefile headers to the new format in my ports.Jimmy Olgeni2013-01-263-15/+0 * Update MASTER_SITES and WWW.MANTANI Nobutaka2013-01-263-11/+13 * Update MASTER_SITES and WWW.MANTANI Nobutaka2013-01-263-9/+10 * Update MASTER_SITES and WWW.MANTANI Nobutaka2013-01-262-8/+10 * Update to version 33.5.0, which mostly brings Qt5 source compatibility.Alexey Dokuchaev2013-01-252-5/+4 * Bump PORTREVISION after DESKTOP_ENTRIES updateMax Brazhnikov2013-01-236-4/+6 * * update to svn 1437264Maho Nakata2013-01-235-44/+5 * - Update DESKTOP_ENTRIES:Max Brazhnikov2013-01-231-2/+2 * * update to svn 1434565Maho Nakata2013-01-212-11/+11 * - Update x11-toolkits/scintilla and editors/scite to 3.2.4Guido Falsi2013-01-182-3/+3 * - Chase lib version changes from ilmbase and OpenEXR updatesSteve Wills2013-01-171-1/+2 * - Update to 3.1.24Grzegorz Blach2013-01-122-3/+3 * - Change MAINTAINER addressThomas Abthorpe2013-01-101-6/+2 * - Update to 0.4.13Sofian Brabez2013-01-093-12/+34 * Remove PKGNAMEPREFIX from textproc/py-ackChris Rees2013-01-081-1/+1 * - Update DESKTOP_ENTRIES:Max Brazhnikov2013-01-071-2/+2 * - Removed empty directory %%DATADIR%%/docSylvio Cesar Teixeira2013-01-071-1/+0 * Convert to new options frameworkBaptiste Daroussin2013-01-061-34/+13 * Convert to New options frameworkBaptiste Daroussin2013-01-061-25/+9 * - update to 5.0.0Jason Helfman2013-01-042-8/+4 * - Update to 3.1.23Grzegorz Blach2013-01-042-3/+3 * Remove the created by me and update those header at the same time. I neverJeremy Messenger2013-01-011-6/+0 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8Beat Gaetzi2012-12-304-0/+12 * - Reassign to the heap at maintainer's requestThomas Abthorpe2012-12-292-12/+4 * update to svn 1425776Maho Nakata2012-12-262-5/+5 * editors/emacs-devel:Ashish SHUKLA2012-12-267-46/+63 * update to svn1424719Maho Nakata2012-12-212-5/+5 * DeforaOS Desktop editorBaptiste Daroussin2012-12-195-0/+35 * Chase icu, graphite2 and libexttextcat bumpBaptiste Daroussin2012-12-192-4/+53 * update to svn 1422198Maho Nakata2012-12-172-5/+5 * Fix package building after Gentium fonts modificationBaptiste Daroussin2012-12-171-1/+1 * - Set default perl version for ports which currently usingAndrej Zverev2012-12-161-1/+0 * Use now global ghostscript descriptionBaptiste Daroussin2012-12-131-2/+1 * Convert to new options frameworkBaptiste Daroussin2012-12-131-17/+11 * - s/spaces/tab/Jose Alonso Cardenas Marquez2012-12-131-5/+5 * - Update to 1.0.4Jose Alonso Cardenas Marquez2012-12-135-49/+32 * - Convert tab to space in WWWBryan Drewery2012-12-131-2/+1 * - Trim headerBryan Drewery2012-12-131-11/+8 * Remove the header for ports I created.Wesley Shields2012-12-131-5/+0 * - Update to version 33.4.0Alexey Dokuchaev2012-12-122-8/+4 * OpenOffice graduates from the Apache IncubatorMaho Nakata2012-12-122-2/+4 * Use system luence.Maho Nakata2012-12-121-0/+5 * - Convert SINGLE OPTION GUI to RADIOBryan Drewery2012-12-121-3/+3 * - Bump port after MagickCore bump.Beech Rintoul2012-12-112-4/+4 * Update PCRE to 8.32Martin Matuska2012-12-114-4/+6 * - Update to 5.2.4Bryan Drewery2012-12-113-6/+6 * Decommissioning java 1.5 (EOLed since October 2009) + removing outdated jdk16Baptiste Daroussin2012-12-113-11/+7 * Decommissioning java 1.5 (EOLed since October 2009):Baptiste Daroussin2012-12-105-24/+8 * - Update MASTER_SITESAlex Kozlov2012-12-101-8/+3 * Revert Chris Petrik's ports to the pool. Thank you for all your work so far,...Eitan Adler2012-12-101-1/+1 * - Update to 2.0.21Marcus von Appen2012-12-092-19/+17 * - Update to 0.9.1Beech Rintoul2012-12-092-9/+6 * - Fix pkgconf dependency declarationPietro Cerutti2012-12-071-1/+1 * - Cleanup the Makefile, NOPORTDOCS -> PORT_OPTIONS:MDOCSAlexey Dokuchaev2012-12-072-12/+26 * - Reset MAINTAINER on ports with addresses that have unrecoverable bounces.Ryan Steinmetz2012-12-071-1/+1 * - Update to 0.4.4Pietro Cerutti2012-12-062-14/+28 * - Take maintainershipPietro Cerutti2012-12-061-6/+5 * - Return maintainership to the pool at maintainer's requestJason E. Hale2012-12-061-6/+2 * - Restore ABI version for xerces-c to make sure xerces-c3 is pickedBarbara Guida2012-12-061-2/+2 * - Update to 1.2.0.9Barbara Guida2012-12-066-104/+231 * - Reset MAINTAINER due to unrecoverable bounceRyan Steinmetz2012-12-051-1/+1 * - Fix build with clang (also cleanup compiler warnings)Pietro Cerutti2012-11-301-18/+158 * - Fix fetchNicola Vitale2012-11-291-0/+1 * 2012-11-26 emulators/gcube: No more public distfilesBaptiste Daroussin2012-11-286-90/+0 * 2012-11-28 editors/glimmer: Depends on the expired gtkglarea through py-gtkBaptiste Daroussin2012-11-2815-339/+0 * Update to svn 1412710.Maho Nakata2012-11-282-5/+5 * - Update to 0.9Pietro Cerutti2012-11-272-10/+7 * - Add upstream patch to fix build with lcms 2.4Jason E. Hale2012-11-091-0/+19 * Remove IGNORE line as now textproc/libexttextcat and textproc/libtextcatMaho Nakata2012-11-072-25/+2 * - Change my email address to gblach@FreeBSD.orgGrzegorz Blach2012-11-041-6/+2 * update to 1405434 and now it uses www/serf.Maho Nakata2012-11-042-7/+7 * Restore 'Created by' header information. This has been removed during theEmanuel Haupt2012-11-041-0/+1 * Update to 3.5.2Max Brazhnikov2012-11-042-3/+3 * Remove the use of _GCC_BUILD_DEPENDS, which was never meant to be usedGerald Pfeifer2012-11-041-7/+3 * Update to svn 1403191.Maho Nakata2012-11-034-41/+17 * - update to 0.57Ruslan Makhmatkhanov2012-11-024-41/+69 * Update to 3.5.1Max Brazhnikov2012-11-022-8/+4 * Deprecated because it depends on the expired gtkglareaBaptiste Daroussin2012-10-291-5/+4 * - Update to 3.5.7.Jung-uk Kim2012-10-27187-747/+306 * Deprecate a bunch of ports that are either abandonware and/or for which no moreBaptiste Daroussin2012-10-261-5/+4 * - Update scintilla and scite to 3.2.3Guido Falsi2012-10-262-9/+4 * - Update to 3.2.2.Raphael Kubo da Costa2012-10-253-32/+18 * Convert to OptionsNGEitan Adler2012-10-201-4/+5 * oops, committed from the wrong directory.Eitan Adler2012-10-201-0/+2 * Convert to OptionsNGEitan Adler2012-10-201-2/+2 * New MASTER_SITE by the new maintainer.Eitan Adler2012-10-201-12/+4 * - Reassign to the heap at maintainer's requestThomas Abthorpe2012-10-161-6/+2 * - cleanup commentsDirk Meyer2012-10-131-5/+0 * Update to 2.1.3Max Brazhnikov2012-10-103-4/+6 * Throw my ports back in the pool, and make my intentions clear for theDoug Barton2012-10-083-10/+3 * Trim the headers in the ports I maintain.Eitan Adler2012-10-062-10/+1 * Change headers of all ports maintained by me to new formatRenato Botelho2012-10-051-5/+1 * - Update to 2.4.9Frederic Culot2012-10-042-8/+4 * - Now, it could build without problemJose Alonso Cardenas Marquez2012-09-301-2/+0 * update to svn 1391327Maho Nakata2012-09-294-33/+5 * Update to Vim 7.3 patchlevel 669.David E. O'Brien2012-09-292-5/+67 * Allowing openjdk7 build.Maho Nakata2012-09-276-1/+325 * Allow openjdk7 build.Maho Nakata2012-09-256-1/+470 * Forgot to add a patch.Maho Nakata2012-09-241-0/+11 * - Fix remote code execution vulnerabilityAshish SHUKLA2012-09-232-0/+28 * - Reassign to the heap at maintainer's requestThomas Abthorpe2012-09-231-4/+2 * update to svn 1388426.Maho Nakata2012-09-223-29/+5 * update to 3.4.1Maho Nakata2012-09-218-1574/+45 * Deprecated a bunch a ports with no more public distfiles (thanks ehaupt'sBaptiste Daroussin2012-09-212-0/+6 * Upgrade to version 5.4Doug Barton2012-09-205-67/+587 * Update to svn 1386922Maho Nakata2012-09-193-7/+29 * - Update Calligra Suite to 2.5.2.Alberto Villa2012-09-1718-34/+52 * Remove pointless header lines from ports I created once upon a time.Christian Weisgerber2012-09-161-5/+0 * - Update to 3.1.22Frederic Culot2012-09-142-3/+3 * Force to use GCC on FreeBSD 8.x, since with clang it builds fine,Alex Dupre2012-09-141-0/+6 * - add license (MIT)Ruslan Makhmatkhanov2012-09-141-0/+2 * Fix build by removing patch.Chris Rees2012-09-131-11/+0 * - Deprecate USE_OPENSSL. It causes nothing but trouble at the moment.Jung-uk Kim2012-09-135-45/+238 * Remove limitation on unthreaded version of Tcl.David E. O'Brien2012-09-121-2/+1 * - Move libxul 1.9.2 to www/libxul19Beat Gaetzi2012-09-111-1/+1 * - Update to 0.68Emanuel Haupt2012-09-102-8/+3 * - Mark BROKEN: does not build:Beat Gaetzi2012-09-091-0/+2 * Welcome back Chris Petrik <c.petrik.sosa@gmail.com>Eitan Adler2012-09-091-1/+1 * Mark broken on powerpc and sparc64 (and presumably, ia64).Mark Linimon2012-09-081-1/+7 * Work around a tinderbox shortcoming.Jung-uk Kim2012-09-081-1/+1 * Chase Emacs updatesAshish SHUKLA2012-09-0512-11/+12 * - Update to version 24.2Ashish SHUKLA2012-09-052-4/+4 * Mark as broken on ARM.Mark Linimon2012-09-041-1/+3 * - Update Calligra to 2.5.1.Alberto Villa2012-09-0139-198/+42 * - Update to 4.1.5770Pietro Cerutti2012-08-304-37/+69 * Fix the previous commit to make it really work. See the following upstreamJung-uk Kim2012-08-301-1/+1 * Work around rpath/origin and visibility issues.Jung-uk Kim2012-08-302-2/+15 * - Update to version 33.3.0Alexey Dokuchaev2012-08-292-6/+7 * The KDE/FreeBSD team is pleased to announce version 2.5 of Calligra,Alberto Villa2012-08-2643-1058/+430 * Fix old-style backquotes issue.MANTANI Nobutaka2012-08-256-143/+163 * Fix old-style backquotes issue.MANTANI Nobutaka2012-08-258-1/+2250 * Fix build error.MANTANI Nobutaka2012-08-256-2/+318 * - Update to 3.5.6.Jung-uk Kim2012-08-24126-302/+857 * Update to 3.5Max Brazhnikov2012-08-232-3/+3 * Fix typo.Max Brazhnikov2012-08-231-1/+1 * Mark BROKEN: does not packageErwin Lansing2012-08-201-0/+2 * Fix GNU configure problem with building "WITH_GNOME2".David E. O'Brien2012-08-181-1/+1 * Update to Vim 7.3 patchlevel 632.David E. O'Brien2012-08-183-4/+148 * Update to svn 1371027Maho Nakata2012-08-153-14/+42 * - Update to 3.2.1Guido Falsi2012-08-144-13/+17 * - Fix a problem handle utf-8 stringJose Alonso Cardenas Marquez2012-08-101-1/+2 * Update to version 33.2.0.Alexey Dokuchaev2012-08-092-3/+3 * - Adjust COMMENT and port descriptions where appropriateAlexey Dokuchaev2012-08-091-2/+2 * - Update to 2.5.5_01Michael Scheidell2012-08-083-45/+59 * - drop .app suffix in portnameDirk Meyer2012-08-08