aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-numpy
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-26 08:52:43 +0800
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-26 08:52:43 +0800
commitcb766f59b12ec4f9680121d9f65c98d0b41ab814 (patch)
tree56eae3b3536f9775a9856585db4ab034c08a71ce /math/py-numpy
parent8f77988d125480c77266f8ec79d544b57ed42018 (diff)
downloadfreebsd-ports-gnome-cb766f59b12ec4f9680121d9f65c98d0b41ab814.tar.gz
freebsd-ports-gnome-cb766f59b12ec4f9680121d9f65c98d0b41ab814.tar.zst
freebsd-ports-gnome-cb766f59b12ec4f9680121d9f65c98d0b41ab814.zip
- Support for -Wl,rpath= in f2py, now passed by bsd.gcc.mk
- Fix build for comms/wsjt PR: ports/164479 Submitted by: maintainer Approved by: gabor (mentor)
Diffstat (limited to 'math/py-numpy')
-rw-r--r--math/py-numpy/Makefile11
-rw-r--r--math/py-numpy/files/patch-numpy-f2py-f2py2e.py18
2 files changed, 24 insertions, 5 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 1cccb3ae8eed..0a50bed91808 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= numpy
PORTVERSION= 1.6.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://docs.scipy.org/doc/${DISTNAME:C/\..$/.0/}/:doc \
@@ -38,10 +39,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/r/rc/}
(${OSVERSION} >= 800000 && ${OSVERSION} <= 800502) || \
(${OSVERSION} >= 900000 && ${OSVERSION} <= 900009)) && \
(${ARCH} == "i386" || ${ARCH} == "amd64")
-USE_FIXED_FENV= yes
+WITH_FIXED_FENV= yes
.endif
-.if defined(USE_FIXED_FENV)
+.if defined(WITH_FIXED_FENV)
MASTER_SITES+= http://svn.freebsd.org/base/head/lib/msun/:fp
.if ${ARCH} == "i386"
FP_ARCH= i387
@@ -80,7 +81,7 @@ post-patch:
GCCLIBDIR_CMDS= ${FC} -print-file-name=libgfortran.so|${SED} -e s/libgfortran.so//
pre-configure:
-.if defined(USE_FIXED_FENV)
+.if defined(WITH_FIXED_FENV)
@if [ "`${PKG_VERSION} -t \"\`\\\`${CC} -print-prog-name=as\\\` --version | ${AWK} 'NR==1 {sub(/\(GNU Binutils\)/,""); print $$3}'\`\" 2.18.49`" = ">" ] ; then \
${CP} ${DISTDIR}/${FP_ARCH}/fenv.c?p=203441 ${WRKSRC}/numpy/core/include/numpy/fenv/fenv.c; \
${CP} ${DISTDIR}/${FP_ARCH}/fenv.h?p=203441 ${WRKSRC}/numpy/core/include/numpy/fenv/fenv.h; \
@@ -102,7 +103,7 @@ pre-configure:
@${REINPLACE_CMD} -e "s+%%GCCLIBDIR%%+$$(${GCCLIBDIR_CMDS})+" ${WRKSRC}/numpy/distutils/system_info.py
pre-install:
-.if defined(USE_FIXED_FENV)
+.if defined(WITH_FIXED_FENV)
@if [ "`${PKG_VERSION} -t \"\`\\\`${CC} -print-prog-name=as\\\` --version | ${AWK} 'NR==1 {sub(/\(GNU Binutils\)/,""); print $$3}'\`\" 2.18.49`" = ">" ] ; then \
${RM} ${WRKSRC}/numpy/core/include/numpy/fenv/fenv.c.bak; \
fi
@@ -115,7 +116,7 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/numpy-ref.pdf ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/numpy-user.pdf ${DOCSDIR}
.endif
-.if defined(USE_FIXED_FENV)
+.if defined(WITH_FIXED_FENV)
@if [ "`${PKG_VERSION} -t \"\`\\\`${CC} -print-prog-name=as\\\` --version | ${AWK} 'NR==1 {sub(/\(GNU Binutils\)/,""); print $$3}'\`\" 2.18.49`" = ">" ] ; then \
${REINPLACE_CMD} -e "s|%%FENV%%||g" ${TMPPLIST}; \
else \
diff --git a/math/py-numpy/files/patch-numpy-f2py-f2py2e.py b/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
new file mode 100644
index 000000000000..0f7f6e96427c
--- /dev/null
+++ b/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
@@ -0,0 +1,18 @@
+--- numpy/f2py/f2py2e.py.orig 2012-01-25 06:59:14.651304791 -0600
++++ numpy/f2py/f2py2e.py 2012-01-25 07:00:58.475075133 -0600
+@@ -514,6 +514,7 @@
+ include_dirs, sources = filter_files('-I','',sources,remove_prefix=1)
+ library_dirs, sources = filter_files('-L','',sources,remove_prefix=1)
+ libraries, sources = filter_files('-l','',sources,remove_prefix=1)
++ extra_link_args, sources = filter_files('-Wl,','',sources,remove_prefix=0)
+ undef_macros, sources = filter_files('-U','',sources,remove_prefix=1)
+ define_macros, sources = filter_files('-D','',sources,remove_prefix=1)
+ using_numarray = 0
+@@ -549,6 +550,7 @@
+ 'undef_macros': undef_macros,
+ 'extra_objects': extra_objects,
+ 'f2py_options': f2py_flags,
++ 'extra_link_args': extra_link_args,
+ }
+
+ if sysinfo_flags: \ No newline at end of file