aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-roman
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-10-28 17:14:20 +0800
committerwen <wen@FreeBSD.org>2011-10-28 17:14:20 +0800
commit0a921fa621473278a9d32b115c233a2f1ed7b31a (patch)
treea719f053813185d5eb5ee550aa820c0a5444f8ce /math/py-roman
parent4653bf1ab78ca9bedcbc18e836c60520642aec25 (diff)
downloadfreebsd-ports-gnome-0a921fa621473278a9d32b115c233a2f1ed7b31a.tar.gz
freebsd-ports-gnome-0a921fa621473278a9d32b115c233a2f1ed7b31a.tar.zst
freebsd-ports-gnome-0a921fa621473278a9d32b115c233a2f1ed7b31a.zip
This is a Integer to Roman numerals converter.
WWW: http://pypi.python.org/pypi/roman/
Diffstat (limited to 'math/py-roman')
-rw-r--r--math/py-roman/Makefile22
-rw-r--r--math/py-roman/distinfo2
-rw-r--r--math/py-roman/pkg-descr3
3 files changed, 27 insertions, 0 deletions
diff --git a/math/py-roman/Makefile b/math/py-roman/Makefile
new file mode 100644
index 000000000000..bf4c2c41d636
--- /dev/null
+++ b/math/py-roman/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-roman
+# Date created: Oct 28, 2011
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= roman
+PORTVERSION= 1.4.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Integer to Roman numerals converter
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/math/py-roman/distinfo b/math/py-roman/distinfo
new file mode 100644
index 000000000000..5aaf61b31f9c
--- /dev/null
+++ b/math/py-roman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (roman-1.4.0.tar.gz) = f7bf0304e2a79279cc06d245b2b7f5a3872cddbaa2932db0cbacc12a77e477ec
+SIZE (roman-1.4.0.tar.gz) = 3033
diff --git a/math/py-roman/pkg-descr b/math/py-roman/pkg-descr
new file mode 100644
index 000000000000..3b82c4fe3ad7
--- /dev/null
+++ b/math/py-roman/pkg-descr
@@ -0,0 +1,3 @@
+This is a Integer to Roman numerals converter.
+
+WWW: http://pypi.python.org/pypi/roman/