aboutsummaryrefslogtreecommitdiffstats
path: root/math/qtiplot/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-14 18:09:05 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-14 18:09:05 +0800
commit9a904eeca16414650f28752e19d8e6782a1bc601 (patch)
tree6b6117244075caaff0e7ce4ab870e404f3b8fa6a /math/qtiplot/Makefile
parenteeb42b8fedfb926d6444befd4fb52710069464c6 (diff)
downloadfreebsd-ports-gnome-9a904eeca16414650f28752e19d8e6782a1bc601.tar.gz
freebsd-ports-gnome-9a904eeca16414650f28752e19d8e6782a1bc601.tar.zst
freebsd-ports-gnome-9a904eeca16414650f28752e19d8e6782a1bc601.zip
Add qtiplot.
The purpose of QtiPlot was to develop a free, platform independent clone of Origin. The result is still far away from its model, but there's a "wish to" list that is being constantly worked on. Features: * Neat 2D and 3D data plotting * ASCII-Import * Spreadsheet and calculations in column-logic * Great non-linear y=f(x) curve fitting and estimation of statistical errors of the fit-parameters WWW: http://soft.proindependent.com/qtiplot.html PR: ports/80849 Submitted by: Jie Gao <gaoj@cpsc.ucalgary.ca>
Diffstat (limited to 'math/qtiplot/Makefile')
-rw-r--r--math/qtiplot/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
new file mode 100644
index 000000000000..51047618a1b0
--- /dev/null
+++ b/math/qtiplot/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: qtiplot
+# Date created: 9 May 2005
+# Whom: Jie Gao <gaoj@cpsc.ucalgary.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtiplot
+PORTVERSION= 0.6.0
+CATEGORIES= math science
+MASTER_SITES= http://soft.proindependent.com/
+
+MAINTAINER= gaoj@cpsc.ucalgary.ca
+COMMENT= An Origin clone for data analysis and scientific plotting
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl \
+ qwt:${PORTSDIR}/x11-toolkits/qwt \
+ qwtplot3d:${PORTSDIR}/math/qwtplot3d
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/qtiplot
+
+USE_QT_VER= 3
+MAKE_ENV= QTDIR=${QT_PREFIX}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not compile on FreeBSD 4.x
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e \
+ "s:/home/ion/qt/qwt-4.2.0/include:${LOCALBASE}/include/qwt:" \
+ -e "s:/home/ion/qt/qwtplot3d/include:${X11BASE}/include:" \
+ -e "/^unix:LIBS/s:-L /usr/lib:-L${LOCALBASE}/lib:" \
+ ${WRKSRC}/qtiplot.pro
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
+ -spec freebsd-g++ qtiplot.pro
+
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; \
+ s|^CXX .*|CXX=${CXX}|; \
+ s|-pipe||; \
+ s|^\(CFLAGS .*= \)|\1${CFLAGS}|; \
+ s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qtiplot ${PREFIX}/bin
+
+.include <bsd.port.post.mk>