aboutsummaryrefslogtreecommitdiffstats
path: root/math/qtiplot
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-07-10 00:02:57 +0800
committermiwi <miwi@FreeBSD.org>2007-07-10 00:02:57 +0800
commita49a0e44d27174a3e61bf1931b1ee622f0823d82 (patch)
treeeb7d5e18612968276bbd656264d35f5618411f5a /math/qtiplot
parent0398074529281afab5c053b49fbb188ce0dc010c (diff)
downloadfreebsd-ports-gnome-a49a0e44d27174a3e61bf1931b1ee622f0823d82.tar.gz
freebsd-ports-gnome-a49a0e44d27174a3e61bf1931b1ee622f0823d82.tar.zst
freebsd-ports-gnome-a49a0e44d27174a3e61bf1931b1ee622f0823d82.zip
- Fix build with python
PR: 114338 Submitted by: Max Brazhnikov <makc@issp.ac.ru> (maintainer)
Diffstat (limited to 'math/qtiplot')
-rw-r--r--math/qtiplot/Makefile12
-rw-r--r--math/qtiplot/files/patch-qtiplot__qtiplot.pro9
2 files changed, 6 insertions, 15 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index adb69ed9f751..16fa32445a77 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -37,7 +37,6 @@ OPTIONS= DOCS "Install the QtiPlot Handbook" on \
.include <bsd.port.pre.mk>
.if defined(WITH_PYTHON)
-BROKEN= py-qt4-\* ports should be fixed first
USE_PYTHON= yes
# manually include this, because USE_PYTHON is defined
# after including bsd.port.pre.mk
@@ -58,7 +57,6 @@ RUN_DEPENDS+= qtiplot-doc>=0:${PORTSDIR}/math/qtiplot-doc
.if !defined(WITHOUT_NLS)
#QT_COMPONENTS+= linguist
BUILD_DEPENDS+= ${LOCALBASE}/bin/lupdate-qt4:${PORTSDIR}/devel/qt4-linguist
-QTI_LANG= de es fr ja ru sv
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -90,18 +88,10 @@ post-configure:
@${REINPLACE_CMD} -e \
's|^CC .*|CC=${CC}|; \
s|^CXX .*|CXX=${CXX}|; \
- s|^LINK .*|LINK=${CXX}|; \
- s|-pipe||; \
- s|^\(CFLAGS .*= \)|\1${CFLAGS}|; \
- s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|' \
+ s|^LINK .*|LINK=${CXX}|' \
${WRKSRC}/${d}/Makefile
.endfor
-do-build:
-.for d in ${QPRO_DIRS}
- (cd ${WRKSRC}/${d}; ${SETENV} ${MAKE_ENV} ${GMAKE})
-.endfor
-
do-install:
${MKDIR} ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/qtiplot/qtiplot ${DATADIR}/qtiplot
diff --git a/math/qtiplot/files/patch-qtiplot__qtiplot.pro b/math/qtiplot/files/patch-qtiplot__qtiplot.pro
index 18bb819b7d10..2252b24c1cc0 100644
--- a/math/qtiplot/files/patch-qtiplot__qtiplot.pro
+++ b/math/qtiplot/files/patch-qtiplot__qtiplot.pro
@@ -1,5 +1,5 @@
---- ./qtiplot/qtiplot.pro.orig Sat Jun 2 15:33:23 2007
-+++ ./qtiplot/qtiplot.pro Sat Jun 2 15:35:21 2007
+--- ./qtiplot/qtiplot.pro.orig Fri Jun 8 00:55:33 2007
++++ ./qtiplot/qtiplot.pro Fri Jun 8 00:58:19 2007
@@ -17,24 +17,17 @@
# what to install and where
@@ -128,7 +128,7 @@
}
-@@ -396,12 +391,11 @@
+@@ -396,12 +391,12 @@
SOURCES += src/PythonScript.cpp src/PythonScripting.cpp
unix {
@@ -141,7 +141,8 @@
+ INCLUDEPATH += $$(PYTHON_INCLUDEDIR)
+ LIBS += -lm -l$$(PYTHON_VERSION)
+ system(mkdir -p $${SIP_DIR})
-+ system($$(PYTHON_VERSION) -c $${SIP_DIR} src/qti.sip)
++ SIPCMD = $$(PYTHON_VERSION) python-sipcmd.py
++ system($$system($$SIPCMD) -c $${SIP_DIR} src/qti.sip)
+ }
win32 {