aboutsummaryrefslogtreecommitdiffstats
path: root/math/rapid/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-21 18:35:44 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-21 18:35:44 +0800
commitc4b5d04df4d5253449e499a96e986ebe80419fe4 (patch)
tree0200b4edc6f09225518d16134e28aa7e351fa3ca /math/rapid/Makefile
parentd3c2479b97a7bd0e67505999d388d732d471c104 (diff)
downloadfreebsd-ports-gnome-c4b5d04df4d5253449e499a96e986ebe80419fe4.tar.gz
freebsd-ports-gnome-c4b5d04df4d5253449e499a96e986ebe80419fe4.tar.zst
freebsd-ports-gnome-c4b5d04df4d5253449e499a96e986ebe80419fe4.zip
- Support staging
- Fix build with a modern clang
Diffstat (limited to 'math/rapid/Makefile')
-rw-r--r--math/rapid/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/math/rapid/Makefile b/math/rapid/Makefile
index 886496453b25..50a0d9b89768 100644
--- a/math/rapid/Makefile
+++ b/math/rapid/Makefile
@@ -19,21 +19,17 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
ALL_TARGET=
MAKE_JOBS_UNSAFE= yes
-MAN1= rapid.1
+MAKE_ENV+= V=1
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-extract:
${REINPLACE_CMD} -E "s/friend RAPID_Collide/friend int RAPID_Collide/" ${WRKSRC}/RAPID_private.H
do-install:
- ${MKDIR} ${PREFIX}/include/RAPID
- ${INSTALL_DATA} ${WRKSRC}/*.H ${PREFIX}/include/RAPID
- ${INSTALL_DATA} ${WRKSRC}/libRAPID.a ${PREFIX}/lib
- ${INSTALL_MAN} ${FILESDIR}/rapid.1 ${MANPREFIX}/man/man1
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/RAPID
+ ${INSTALL_DATA} ${WRKSRC}/*.H ${STAGEDIR}${PREFIX}/include/RAPID
+ ${INSTALL_DATA} ${WRKSRC}/libRAPID.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_MAN} ${FILESDIR}/rapid.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.post.mk>