aboutsummaryrefslogtreecommitdiffstats
path: root/math/rcalc/Makefile
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 15:17:31 +0800
committerreg <reg@FreeBSD.org>2000-10-05 15:17:31 +0800
commit68dad4980b984b6c03859651af5eefb37c1c9d90 (patch)
treea1b402b639681e7623529a2295404459e0d45edf /math/rcalc/Makefile
parent30fb8569371544b140cbfbe9d8d545a551b7a815 (diff)
downloadfreebsd-ports-gnome-68dad4980b984b6c03859651af5eefb37c1c9d90.tar.gz
freebsd-ports-gnome-68dad4980b984b6c03859651af5eefb37c1c9d90.tar.zst
freebsd-ports-gnome-68dad4980b984b6c03859651af5eefb37c1c9d90.zip
Implement USE_GNOME, part 2.
Diffstat (limited to 'math/rcalc/Makefile')
-rw-r--r--math/rcalc/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/math/rcalc/Makefile b/math/rcalc/Makefile
index e4b7fd4bdea2..a10d44da8d98 100644
--- a/math/rcalc/Makefile
+++ b/math/rcalc/Makefile
@@ -14,16 +14,15 @@ DISTNAME= rCalc-${PORTVERSION}
MAINTAINER= jedgar@FreeBSD.org
-LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-x
-CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
- GTK_CONFIG="${GTK_CONFIG}" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+pre-patch:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'
+
.include <bsd.port.mk>