aboutsummaryrefslogtreecommitdiffstats
path: root/math/saga
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-09-09 13:30:32 +0800
committermakc <makc@FreeBSD.org>2010-09-09 13:30:32 +0800
commit03026960173d03580778bb24e5155b33d8268048 (patch)
tree42472ea8c61f99a84d647694ddcb445f76234922 /math/saga
parente6d4091576b34c9f1d456bd6339b83b6d300cc50 (diff)
downloadfreebsd-ports-gnome-03026960173d03580778bb24e5155b33d8268048.tar.gz
freebsd-ports-gnome-03026960173d03580778bb24e5155b33d8268048.tar.zst
freebsd-ports-gnome-03026960173d03580778bb24e5155b33d8268048.zip
Fix build on i386
Reported by: pointyhat Submitted by: Rainer Hurling (maintainer)
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 21216ad63b98..de2df7107265 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -33,12 +33,14 @@ MAN1= saga_cmd.1 saga_gui.1
DESKTOP_ENTRIES= "SAGA GIS" "${COMMENT}" "${DATADIR}/saga_icon_32.xpm" \
"saga_gui" "Application;Math;" true
-OPTIONS= UC "Enable Unicode Support" On \
+OPTIONS= UNICODE "Enable Unicode Support" On \
HARU "Enable Haru Free PDF Library (optional)" Off
.include <bsd.port.options.mk>
-.if defined(WITH_UC)
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_UNICODE)
WITH_UNICODE= yes
CONFIGURE_ARGS+= --enable-unicode
.else
@@ -64,6 +66,10 @@ post-patch:
${WRKSRC}/src/modules_io/esri_e00/io_esri_e00/e00compr/cpl_port.h \
${WRKSRC}/src/modules_io/grid/io_grid_grib2/g2clib-1.0.4/enc_png.c \
${WRKSRC}/src/modules_projection/pj_georeference/pj_georeference/lmdif0.c
+.if ${ARCH} == "i386"
+ @${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
+ ${WRKSRC}/src/saga_core/saga_api/api_core.h
+.endif
post-install:
${MKDIR} ${DATADIR}
@@ -71,4 +77,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/xpm/saga_icon_32.xpm ${DATADIR}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>